Jump to content
Sign in to follow this  
Rick

updating from 3.2.5.2

Recommended Posts

Rick

Hi , I'm considering updating to AutoIt v3.2.11.10, altho it concerns me it will break quite a few if not all of my scripts from the passed 2yrs.

Before i update, is there a utility within the new version to convert older scripts or will this have to done manually??

Many thanks, rick


Who needs puzzles when we have AutoIt!!

Share this post


Link to post
Share on other sites
PsaltyDS

Hi , I'm considering updating to AutoIt v3.2.11.10, altho it concerns me it will break quite a few if not all of my scripts from the passed 2yrs.

Before i update, is there a utility within the new version to convert older scripts or will this have to done manually??

Many thanks, rick

Gotta' take the bad with the good. There have been a lot of improvements since 3.2.5.2, but you will have to manually tweak your scripts.

Make sure you do your updates on copies of the sources, not the originals.

Make sure you are using a current version of SciTE, so the syntax checker can help you out.

You will find PaulIA's AutoIt3Lib functions incorporated into the distribution, but renamed to fit with conventions of other UDFs. For example _TreeView_Create() from A3LTreeView.au3 would now be _GUICtrlTreeView_Create() from GuiTreeView.au3. They were substantially rewritten by Gary Frost, so compare the syntax too.

Also, you will find a need for more #include's with the native functions, because a design decision was made to break up the huge include files of constants (like GuiConstants.au3) into many smaller ones. For example, a label control created with GuiCtrlCreateLabel() with the $SS_CENTER style would require #include <StaticConstants.au3>. Review the new help file for these functions. When you follow the links for the various Styles and Extended Styles, each table lists the required #include file at the top.

Good luck with it!

:)

Edited by PsaltyDS

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites
Zedna

I recommend to upgrade to release version 3.2.10 first.

There are not changed #include files - this change comes along with 3.2.11.xx betas

Also look at great helper utility "Organize includes" which will help you in migrating process to 3.2.11.xx version

by adding needed #include files.

http://www.autoitscript.com/forum/index.php?showtopic=55368

Share this post


Link to post
Share on other sites
Rick

ok, many thanks. Looks like I've a few busy weekends ahead.

The reason I had'nt previously updated was cos there seem to be updates almost daily at one point and it got to the stage where I couldnt trust em so didnt update. I see the last few months things have settled down a bit so time to see whats new.

Thanks guys

Edited by Rick

Who needs puzzles when we have AutoIt!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×