Jump to content
Sign in to follow this  
Perez

MouseClick, MouseMove, Send not working on Vista64bit

Recommended Posts

Perez

Hi,

I have a strange problem:

I recently installed Vista 64 bit.

I wrote a script which is opens the command line and sends some characters, but it doesn't work on Vista 64 bit. It works on XP 32 bit

Here is the script:

Run ("cmd")

WinWaitActive ("C:\Windows\system32\cmd.exe")

Sleep (2000)

Send ("ping 192.168.1.123")

Or:

Run ("cmd")

WinWaitActive ("C:\Windows\system32\cmd.exe")

WinMove ("C:\Windows\system32\cmd.exe","",0,0)

Sleep (2000)

MouseClick ("right",270,170)

Perez

Share this post


Link to post
Share on other sites
d4rk

are you sure the folder name is Windows or WINDOWS ?


[quote]Don't expect for a perfect life ... Expect a least troubles ones[/quote]Contact me : ass@kiss.toWhat I Have Done :Favorites Manager Mangage your favorite's folder, that's coolPC Waker For those who want to save stickersWebScipts Supporter For those who've just started with Web and WebScriptsTemporary Looker Simple but powerful to manage your Temporary folder, you know what you downloaded[UDF] _NumberFormat() Better performance on number display[UDF] _DirGet() What a folder contain [how many (hidden,normal,...) files], with one line of code[UDF] _IsPressEs() Just like _IsPress() but for a group of keys

Share this post


Link to post
Share on other sites
Perez

are you sure the folder name is Windows or WINDOWS ?

Yes, it is Windows. (I checked with the WindowInfo tool)

The WinWaitActive and the WinMove is working. The problem is that the Send not sends any characters (keys) to the command window.

And the MouseClick or MouseMove is not working if the command window is active.

Perez

Share this post


Link to post
Share on other sites
Perez

Yes, it is Windows. (I checked with the WindowInfo tool)

The WinWaitActive and the WinMove is working. The problem is that the Send not sends any characters (keys) to the command window.

I figured out how to make it work:

If I use this:

RunAsSet ("username",@Computername,"password")

Run ("C:\Windows\system32\cmd.exe")

WinWaitActive ("C:\Windows\system32\cmd.exe")

Sleep (2000)

Send ("ping 192.168.1.123")

Send ("{ENTER}")

It's working!

Perez

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×