Sign in to follow this  
Followers 0
Yorn

_INetSmtpMail error code 2

1 post in this topic

I have a custom technical support app I've written that emails our help desk when our users have problems. It send an attached screenshot along with computer and user information. The problem I am having is with a handful of computers that *never* send email with _INetSmtpMail() and always error with code 2. It's only a few computers out of one thousand, but it looks like the part that will error to a 2 is this:

; Sent the Message
$objEmail.Send
If @error Then
    SetError(2)
    Return $oMyRet[1]
EndIf

Now the error that would happen on Send is for the object "CDO.Message", but that's as far as I've gotten. The user doesn't have any weird username, the email address looks normal, the attachment is no different from the thousands of others that are using the program just fine. Is there any quirks or anything with CDO.Message that I need to know about? It's a COM object, I believe, not an AutoIt-specific question, but I figured someone might know a thing or two about what types of errors it throws and how to maybe capture that for my troubleshooting.

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0