Jump to content
Sign in to follow this  
SxyfrG

Disable Au3check ... ? [Solved]

Recommended Posts

SxyfrG

I've recently upgraded to the latest SciTE4AutoIT3, and it's really frustrating me.

Well not SciTE itself, but the great and helpful program that comes with it, Au3Check.

Now in previous versions Au3Check has been really helpful, only debugging to the little console window down the bottom.

But with this new SciTE4AutoIT3 it continually pops up with an alert box with any errors/warnings when i press F5 and this is what is really frustrating me.

Is there anyway to disable this little feature of Au3Check?

*EDIT*

The problem lies with Au3Wrapper.exe. Is there any way to stop it showing that annoying alert box?

Edited by SxyfrG

My scripts:AppLauncherTRAY - Awesome app launcher that runs from the system tray NEW VERSION! | Run Length Encoding - VERY simple compression in pure autoit | Simple Minesweeper Game - Fun little game :)My website

Share this post


Link to post
Share on other sites
Hok

Well you could always go back to the old version... if possible.

Share this post


Link to post
Share on other sites
SxyfrG

Well you could always go back to the old version... if possible.

I'd rather not have to.

This alert box that pops up, to me, seems like overkill.

The little console window in SciTE is there to tell me i've got errors with my script or spit warnings at me, but this new box thing is just ... BLEAH >_>

I may as well edit the AutoIT3_Wrapper.au3 file so it doesn't show that stupid box >:\

*EDIT*

Oh well, i give up.

Maybe next release they'll include an option to banish that stupid box that pops up at the end of Au3Check in AutoIT3Wrapper >:\

Edited by SxyfrG

My scripts:AppLauncherTRAY - Awesome app launcher that runs from the system tray NEW VERSION! | Run Length Encoding - VERY simple compression in pure autoit | Simple Minesweeper Game - Fun little game :)My website

Share this post


Link to post
Share on other sites
Jos

Maybe next release they'll include an option to banish that stupid box that pops up at the end of Au3Check in AutoIT3Wrapper >:\

The Au3Check box has always come up when au3check detects errors and, by default, doesn't when only warnings are shown.

this for example doesn't show the msgbox:

Test()

$b=$a

Func test()
    Global $a=1
EndFunc

It makes sense to me that the popupbox is always shown on errors since you need to be able to stop the Run/Compile process at that time.

Now maybe you could tone down a bit and be more clear and give an example what you think never gave an popup box before when using AUtoIt3Wrapper.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
SxyfrG

Sorry for sounding angry before, it was just really frustrating me :\

Before, i had only ever used the light version of SciTE that comes with the installation package of AutoIT.

But now i've upgraded to the SciTE4AutoIT3 (for v3.12.0.0), and although all the new things that come with it far outweigh that slight annoyance, it's still a bit frustrating.

I'll just sit back and deal with it ...

Sorry for ranting, but hormones got the better of me this time :|


My scripts:AppLauncherTRAY - Awesome app launcher that runs from the system tray NEW VERSION! | Run Length Encoding - VERY simple compression in pure autoit | Simple Minesweeper Game - Fun little game :)My website

Share this post


Link to post
Share on other sites
Jos

Sorry for sounding angry before, it was just really frustrating me :\

Before, i had only ever used the light version of SciTE that comes with the installation package of AutoIT.

But now i've upgraded to the SciTE4AutoIT3 (for v3.12.0.0), and although all the new things that come with it far outweigh that slight annoyance, it's still a bit frustrating.

I'll just sit back and deal with it ...

Sorry for ranting, but hormones got the better of me this time :|

Ok, now I understand where you are coming from... you were not running au3check before.

Well,I think it is a good practice to run it and have it run without errors/warnings because that will prevent AutoIt3 errors at runtime, but when you really don't want to run au3check you have 2 options:

1: add this directive to the script:#AutoIt3Wrapper_Run_AU3Check=n

2: Update the AutoIt3Wrapper.ini and set this field:

[Other]
Run_AU3Check=

Option 2 will disable the au3check by default.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Jos

:) :) :)

Thank you Jos :(

:P Don't tell anybody that i turned it off :(

Hey, when you are the "perfect" coder you don't need it. I am more the "human" coder and make mistakes all the time. :o

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×