Jump to content
Sign in to follow this  
md9

Aargh! Unable to access Treeview Items

Recommended Posts

md9

Hi all,

I am posting this in GUI Support group to see if someone has a smart solution.

I have a tree control in a window (Example: with a handle 0x0007068A,) and when I open up the tree node, all the children have the same handle. Which makes it difficult to capture individual items, Also using _GUICtrlTreeView_GetChildCount on this node would result in -1. Only thing that changes is the mouse coordinates when I check using AUTO IT Window Info.

Did someone face this issue before, Is there a work around? none of the API call work without a windows handle. Any help is going to be very helpful.

- MD :)

Share this post


Link to post
Share on other sites
covaks

Is this a treeview in a GUI you created or an external app? If it's an external app can you tell us which one? Show us your code as well.

Some of the commands require the handle to the control, and not the window, so make sure you are using the right handle. It's not clear from your post whether you've made that distinction. Also, the items in the treeview will not have seperate handles, which is what it sounds like you are looking for. You get the handle to the control itself, and the contents of the control are generally manipulated by item index.

Share this post


Link to post
Share on other sites
Siao

1) Creating two topics for the same question is not necessary.

2) Window handle and treeitem "handle" operate in different contexts. A window is not a treeitem, and treeitem is not a window. You cannot expect things to work by using one instead of another wherever it pleases you.


"be smart, drink your wine"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×