Jump to content
Sign in to follow this  
layer

why does mousegetpos return 1 in loop?

Recommended Posts

layer

hey guys... just messing around and i tried to make a script that recorded the positions of where your mouse is all the time... now im sure it can be done in dllcall but id like to know why this just returns 1 when it should be 2 arrays...

While 1
   $pos= MouseGetPos ()
   FileWriteLine ("mousemove.txt", $pos[0] and $pos[1])
   WEnd

check the mousemove.txt on wherever this script is and youll see just a bunch of ones... why is this? :D

EDIT: hmmm... i ran if for a few mins, scrolled down the 1's and saw a few 0's too! :idiot:

Edited by layer

FootbaG

Share this post


Link to post
Share on other sites
layer

heh, sorry, that works :idiot: thanks!


FootbaG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.