Sign in to follow this  
Followers 0
billgoss7

Page has buttons showing but html source doesn't show them

5 posts in this topic

Good Morning!

WILLIAM GOSS

As you can see, when I try to do a copy/paste of the screen that I want to press one of the 4 buttons, the four buttons don't show up between the Good Morning! and the time of 10:35:16

10:35:16 AM

That is my problem. I got the first screen to process my input and produce this second screen and I have no idea of how to get to click one of the buttons on the left side of the screen. The source of the screen:

<HTML>

<TITLE>Substitute</TITLE></HEAD>

<frameset Cols="20%, *" method=post>

<frame frameborder="no" name="option_window" src="../sub/SubOptions.asp">

<frame frameborder="no" name="workarea_window" src="../common/Message.asp">

</frameset>

</HTML>

I believe that in the "option window" ("../sub/SubOptions.asp") is where the 4 buttons are, but all I can find is onmouseover, onmouseout, ONMOUSE UP, AND onmousedown.

Any help would be appreciated--also where do I find a list of _IE script commands?

billgoss

Share this post


Link to post
Share on other sites



-also where do I find a list of _IE script commands?

billgoss

In the help believe it or not!

Search for _IE* and press Enter and you will see a list of functions.

(I can't help you with the rest.)


Serial port communications UDF Includes functions for binary transmission and reception.printing UDF Useful for graphs, forms, labels, reports etc.Add User Call Tips to SciTE for functions in UDFs not included with AutoIt and for your own scripts.Functions with parameters in OnEvent mode and for Hot Keys One function replaces GuiSetOnEvent, GuiCtrlSetOnEvent and HotKeySet.UDF IsConnected2 for notification of status of connected state of many urls or IPs, without slowing the script.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

if you copy/paste a page buttons will not copied since they are

1. pictures that works as links (img src and a href)

2. submit form (INPUT type=submit)

if it's a framepage look at the source and open up every frame and look at the source for every frame.

btw you forgot to open the head tag...

but try with _IEFormSubmit and see if it works

that's all I can help you with since you didn't posted any link to the page or any script.

Edited by Pain

Share this post


Link to post
Share on other sites

since its a frameset you need to load "../sub/SubOptions.asp" directly the the _ie functions , then see what is being displayed here in the html code

Share this post


Link to post
Share on other sites

Also see my sig for DebugBar - makes DOM and source investigation simple.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0