Sign in to follow this  
Followers 0
Champak

AfxWnd getting text problem

3 posts in this topic

I responded in an old thread with this issue, but didn't like the title of the thread (didn't think it really conveyed my issue) so I started my own.

I'm seeing a control...it's a listbox or a listview I don't know...and I'm trying to get the text from it and I can't. The class is afxwnd. I've seen around the net that you can't retrieve text in controls with this class. I was wondering if it is the same problem with autoit?

Share this post


Link to post
Share on other sites



I responded in an old thread with this issue, but didn't like the title of the thread (didn't think it really conveyed my issue) so I started my own.

I'm seeing a control...it's a listbox or a listview I don't know...and I'm trying to get the text from it and I can't. The class is afxwnd. I've seen around the net that you can't retrieve text in controls with this class. I was wondering if it is the same problem with autoit?

AutoIt is very cool, but it is not magic. It still uses standard Windows APIs to do stuff. If that control is not part of the standard APIs then AutoIt doesn't know what to do with it.

One thing you might be able to do is standard keyboard operations that are not control specific. If you manually give focus to that control and do Alt-a then Alt-c, do you get anything? If so, as a worst case, you ControlSend() those.

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

AutoIt is very cool, but it is not magic. It still uses standard Windows APIs to do stuff. If that control is not part of the standard APIs then AutoIt doesn't know what to do with it.

One thing you might be able to do is standard keyboard operations that are not control specific. If you manually give focus to that control and do Alt-a then Alt-c, do you get anything? If so, as a worst case, you ControlSend() those.

:)

I am having the same problems getting a AfxWnd to do anything. I have managed to get the text via

ClipPut("")
send("{F2}")
sleep(250)
send("^c")
sleep(250)
send("{F2}")
$alpha = ClipGet()

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0