Jump to content
Sign in to follow this  
engine

Null problem with COM

Recommended Posts

engine

Well. When using COM on VBScript, null, "" (empty string) and 0 are totally different. While for AutoIt an empty string seems to be the same as null. So there isn't a way to specify null when using Objects with AutoIt. An empty string simply doesn't work. A 0 is always a 0! This seriously limits what you can do with COM on AutoIt.

Are there any plans to overcome this?

Edited by engine

My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites
ptrex
LarryDalooza

Hi.

Now I am having the same problem with DllCalls. Neither 0, "", Default and Chr(0) are working.

For the love of jeebus!!! do not make us start a session of 20 questions!!!

Lar.


f_mrcleansmalm_77ce002.jpgAutoIt has helped make me wealthy

Share this post


Link to post
Share on other sites
engine

I am sorry, Larry.

Problem solved!

I was using this -> http://msdn.microsoft.com/en-us/library/ms681987(VS.85).aspx

My mistake was that I was translating "LPDWORD" to "dword*". When I also changed that one to '"ptr", 0' the call worked as expected.

Kind regards.

Edited by engine

My contributions:Local account UDF Registry UDFs DriverSigning UDF Windows Services UDF [url="http://www.autoitscript.com/forum/index.php?showtopic=81880"][/url]

Share this post


Link to post
Share on other sites
Valik

Let me point out the things you've done wrong.

  • You didn't stop to think about your issue.
  • You posted an unrelated question in an existing thread.
  • You posted an ambiguous question.
  • When asked for more detail, you didn't really provide anything useful. You could have been just as helpful typing random characters.
It's a good thing you solved the problem on your own because you hadn't given enough detail for anybody else, except a psychic, to solve it.

Thread locked to discourage you from doing #2 again, at least.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×