Sign in to follow this  
Followers 0
tourcd

GUICtrlCreateEdit @CRLF Send Problem

4 posts in this topic

I've created a simple script which has a GUI with a GUICtrlCreateEdit function.

I'm then using a GUICtrlRead and Send to write the text in to a new message in Outlook.

If I put more than one line in to the GUICtrlCreateEdit dialog box then my application stops when it tries to send Outlook the second line.

It seems to send @CRLF characters instead of @CR and Outlook doesn't like it.

Is there anyway you can use the 'Send' function but replace @CRLF with @CR in a string collected by GUICtrlCreateEdit?

Share this post


Link to post
Share on other sites



@tourcd...I personally hate the "Send" command. If you are trying to automate sending a message via Outlook, then you should look into the ObjCreate("Outlook.Application") method. Search the forum and I am sure you will find many topics.

Share this post


Link to post
Share on other sites

Thanks I'm new to Autoit and I thought Send looked easy to use, I'll try the ObjCreate method instead.

Share this post


Link to post
Share on other sites

Hmm, it seems that method won't work with Outlook Express 6, I don't have a copy of Outlook to work with.

Do you or anybody else have another ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0