Sign in to follow this  
Followers 0
adapagol

Notepad automation not working

10 posts in this topic

Hi

I am a new user of Autoit v3. I have just started learning Autoit. But when I read the tutorial and run the example program ,'notepad automation' it does not work accordingly .But I can see lots of icons in my taskbar , and it continues creating such icon though I dont see any appearance of notepad in the screen. Here I like to mention that I always close the notepad application before running the script. Can anybody solve the problem plz?

Share this post


Link to post
Share on other sites



let me guess: You called your script notepad.au3 ?

Tks for reply. No i wrote exactly same as in tutorial Run("notepad.exe"). but it doesnt work Plz help me.

Share this post


Link to post
Share on other sites

Tks for reply. No i wrote exactly same as in tutorial Run("notepad.exe"). but it doesnt work Plz help me.

Ok lets see:

1. What Editor did you use?

2. What did you call the file?

3. How did you run it ?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

He meant did you save your script as: notepad.au3

Then the script thinks itself is the notepad.exe you Run()

Only when you compile the notepad.au3 to notepad.exe. :)

Try saving you script as: notepadtester.au3.

just renaming will not solve anything unles the notepad.exe compiled script is also deleted!

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Only when you compile the notepad.au3 to notepad.exe. :)

just renaming will not solve anything unles the notepad.exe compiled script is also deleted!

Jos

Millions of thanks infinite of thanks to both of u.Now I am able to solve the problem. Firstly I actually created the script file as notepad.au3.Now i deleted it's exe file also and wrote a new one with different name and it is working properly. Thank you very much ..

Share this post


Link to post
Share on other sites

Millions of thanks infinite of thanks to both of u.Now I am able to solve the problem. Firstly I actually created the script file as notepad.au3.Now i deleted it's exe file also and wrote a new one with different name and it is working properly. Thank you very much ..

So my first guess was correct. :)

Enjoy

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

So my first guess was correct. :P

Enjoy

Jos

Gotta love the "Guessing-Game" we have to play, just to help someone... :)

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Only when you compile the notepad.au3 to notepad.exe. :)

just renaming will not solve anything unles the notepad.exe compiled script is also deleted!

Jos

Ah, good tip :P

I didn't think about that. (Didn't need the anwser anyway _YET_)


My active project(s): A-maze-ing generator (generates a maze)

My archived project(s): Pong3 (Multi-pinger)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0