Sign in to follow this  
Followers 0
steve8tch

IIS and autoit

6 posts in this topic

For any of you webserver gurus out there..

I can't find anything on Forum.

Share this post


Link to post
Share on other sites



IIS and autoit, Has anyone got this to work yet.

For any of you webserver gurus out there..

I can't find anything on Forum.

Got what to work? What about IIS? What are you trying to do? What did you try? What happened when you tried it?

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Hi PsaltyDS,

It was a bit of an open ended question :)

My question was really directed at people far cleverer that me - who have been able to get autoit running as one of the web server side scripting languages.

Unfortunately - in our company - all the Windows based webservers use IIS.

I have got tcl working on an apache server and that is great - but the place I need to get some scripts running now are applications running on Windows.

Just for your information - I want to enable users on company LAN to use a web front end to allow them the query (and maybe some control) hundreds of headless computers attached to production tools. As indicated above - I have been able to do this with apache and tcl - in a way that is applicable for applications hosted on those servers, now I have different servers and different applications and I would like to use the same mechanism.

So I suppose my original question still stands -

IIS and autoit, Has anyone got this to work yet ?

Thanks.

Share this post


Link to post
Share on other sites

@steve8tch

I had the same question long time ago

AU3 on IIS

When you start reading from there on, you will find out that no one ever gave me the answer.

First I thought I would have found the solution in FAST CGI .

But never got started whit that.

So my recomendation is use my alternative called Webbased AU3 on LightTD

It runs from a thumbdrive if needed. Nothing to install at all.

Regards,

ptrex

Share this post


Link to post
Share on other sites

OK - I think I have got this working on IIS running on my laptop.

XP SP2

IIS 5.1 ?

The trick to making with work was the following.

Configure Website Properties | Home directory | Application settings | Configuration.

Add Autoit as application mapping.

The real trick to making this work was the following.

The page headers had to be exactly the following - anything else did not work correctly.

ConsoleWrite('<Status: 200 OK' & @LF)
ConsoleWrite('<Content-type: text/html' & @LF& @LF& @LF)oÝ÷ جyÛayú%"h¦'$ºZ­©µê쥫,yÖÞ·Ç+ljëh×6$my_input = StringReplace(EnvGet('QUERY_STRING'),"%20"," ")

After that it just worked.

What I really want to know is if this will work on Server 2003 - I will have to test

I hope this helps someone muttley

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0