Sign in to follow this  
Followers 0
muzle6074

Help please! I can't compile/run au3!

9 posts in this topic

For some reason, and I don't know why I can't compile any au3 scripts! I got an error compiling the script and then an error trying to run the exe. I had beta installed but I un-installed both beta and 3.2 with a fresh install but I still get the errors! muttley

Someone please help me! Here are two screen shots of both errors.

Regards.

Compile error:

Posted Image

Run error:

Posted Image

Share this post


Link to post
Share on other sites



How are you compiling ?

What is the name of the input script file?

Does the output exe already exist and is it running?

When using SciTE: show the Output pane info for F5 and F7.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Hi Jos,

I'm compiling by right clicking the script and selecting "Compile Script".

I'm not sure what you mean by input file but if you mean the name of the script it varies. :(

The .exe does not exist as the names of the scripts vary and i tested it with a random names like "Fsd3her423fsdfd".

What is SciTE?

Sorry I'm still not familiar with a few autoit terms, please explain so I can answer more questions if it helps.

Regards.

EDIT: I just compiled using F7 and it worked! :) Thank you so much. I wonder why I can't quick compile with right-click muttley

Edited by muzle6074

Share this post


Link to post
Share on other sites

Hi Jos,

I'm compiling by right clicking the script and selecting "Compile Script".

I'm not sure what you mean by input file but if you mean the name of the script it varies. :(

The .exe does not exist as the names of the scripts vary and i tested it with a random names like "Fsd3her423fsdfd".

What is SciTE?

Sorry I'm still not familiar with a few autoit terms, please explain so I can answer more questions if it helps.

Regards.

EDIT: I just compiled using F7 and it worked! :) Thank you so much. I wonder why I can't quick compile with right-click muttley

Can you compile with F5 as well?

Your registry settings may be screwed up for the context menu options to compile by right clicking.


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Can you compile with F5 as well?

Your registry settings may be screwed up for the context menu options to compile by right clicking.

Yeah, when I'm in the script editor and I hit F5 it runs the script as it should and F7 will compile it but the right click thing throws the errors muttley

Share this post


Link to post
Share on other sites

Try running attached script to fix the registry.

You need to copy it to the AutoIt3 Program directory and then run it.

Jos

Fix_AutoIt3Help_and_FileExt_Association.au3


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I ran the script but I still can't compile with right-click then compile with running both the "run" and "edit" from the script.

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

I ran the script but I still can't compile with right-click then compile with running both the "run" and "edit" from the script.

muttley ... ok I understood that the script didn't fix it but the rest is abacadabra to me.. :) Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

My apologies Jos, I didn't say thank you for that it's useful now with auto edit mode! :)

Thanks muttley

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0