Sign in to follow this  
Followers 0
Aiakonai

Combo box not returning correct contents

2 posts in this topic

I'm having trouble getting correct data from a combo box.

The following Functions are where the error occurs.

Func RC_addperson()
    Dim $comboText = _GUICtrlComboBox_GetEditText($RC_mainUserListBox)
    debug("combo text in addperson = ",$comboText)
    RC_connectTo($comboText)
EndFunc

Func RC_connectTo($uid)
    debug("uid",$uid)
    If _GUICtrlComboBox_FindStringExact($RC_mainUserListBox,$uid) <> -1 Then
        debug("valid entry in ", "RC_connectTo")
        $connectionList[0] = $uid
        RC_createChatWindow($uid)
    Else
        debug("invalid entry in ","RC_connectTo")       
    EndIf
EndFunc

When I run the program in Xp it reads from the combo box correctly, but

when I run it in Win2k It does not return what I put in the box.

Does anyone know why this might be happening?


hmm... I wonder which key is the any key :O

Share this post


Link to post
Share on other sites



I apologize .. apparently I should have been using guictrlread() instead.

It still seems kinda strange that the function especially designed for doing this does not work in win2k.

But for now the problem is solved.


hmm... I wonder which key is the any key :O

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0