Jump to content
Sign in to follow this  
NoobBK

COM issue with Microsoft Virtual Server

Recommended Posts

NoobBK

Hi all !

I want to code some scripts by AutoIT to control my virtual machine on Virtual Server. So i read about Virtual Server COM API on Technet and try one of scripts http://www.microsoft.com/technet/scriptcen...3.mspx?mfr=true

Script Code

CODE
On Error Resume Next

Set objVS = CreateObject("VirtualServer.Application")

Set objVM = objVS.FindVirtualMachine("Windows 2000 Server")

objVM.Notes = "This is a Windows 2000 virtual machine."

Code for AutoIT

$objVS = ObjCreate("VirtualServer.Application")
$objVM = $objVS.FindVirtualMachine("Windows 2000 Server")
$objVM.Notes = "This is a Windows 2000 virtual machine."

When i run it. I reviced error

The requested action with this object has failed.:

$objVM = $objVS.FindVirtualMachine("Windows 2000 Server")

$objVM = $objVS.FindVirtualMachine("Windows 2000 Server")^ ERROR

Pls help me to fix this issue.

Share this post


Link to post
Share on other sites
Legacy99

Good luck with this one, I tried for half a day to get a couple of Virt. Servers to save state and/or merge disks for backup purposes. I gave up after facing the same issues and resorted to VB. Probably could have used Powershell too but I'm too lazy to learn it right now.

Share this post


Link to post
Share on other sites
DaleHohm

First make certain that the vbs code works for you.

Next, check IsObj() on the abject variables to insure they were set properly. Next set up a COM error handler to see if you get more information (see the helpfile of use the one from IE.au3 with _IEErrorHandlerRegister() )

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
FreeFry

First make certain that the vbs code works for you.

Next, check IsObj() on the abject variables to insure they were set properly. Next set up a COM error handler to see if you get more information (see the helpfile of use the one from IE.au3 with _IEErrorHandlerRegister() )

Dale

I think that you're going to have to explain that. :P

I might be wrong though, and the OP actually understands what you're suggesting. :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.