Sign in to follow this  
Followers 0
Jac

Line -1 Error: Variable must be of type "Object"

3 posts in this topic

Ive made a login script with autoit that is lauch when the user logon on the domain

On some pc, i have this error Line -1 Error: Variable must be of type "Object"

Can somebody explain me what it is? How can i debug that error ?

Thanks

Jac

Share this post


Link to post
Share on other sites



I kept getting this while trying to make a Rich Text object before. Must be a bug in the new beta, like how you cant use styles, unless you use the 0x###### values.


-Joscpe

Share this post


Link to post
Share on other sites

I kept getting this while trying to make a Rich Text object before. Must be a bug in the new beta, like how you cant use styles, unless you use the 0x###### values.

Don't get people thinking there are bugs when you probably haven't even submitted bug report and haven't received a confirmation on such a thing.

You need to trap COM errors, there are examples all over the forum, and within IE.au3 itself (assuming you are using IE.au3.). Use _IEErrorHandlerRegister to trap them.


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0