Sign in to follow this  
Followers 0
Spiff59

Populating image tooltip in ListView?

3 posts in this topic

I have a ListView displaying images in the first column and noticed when I create the ListView with the $LVS_EX_INFOTIP style, that hovering over any of the images displays a blank tooltip. I'd like to put a description of what the differing types of images represent into each tooltip.

The image indicates the status of a record (one per ListView row). I have 5 different images presently. Since the images and their descriptions do vary by row, I'm half-expecting to be adding something into my WM_NOTIFY routine?

Thank you.

Share this post


Link to post
Share on other sites



I have a ListView displaying images in the first column and noticed when I create the ListView with the $LVS_EX_INFOTIP style, that hovering over any of the images displays a blank tooltip. I'd like to put a description of what the differing types of images represent into each tooltip.

The image indicates the status of a record (one per ListView row). I have 5 different images presently. Since the images and their descriptions do vary by row, I'm half-expecting to be adding something into my WM_NOTIFY routine?

Thank you.

So, the tooltip, that appears on a ListView image when $LVS_EX_INFOTIP is enabled, is unusable?

Share this post


Link to post
Share on other sites

Bump! (I did wait 6 months!)

Rephrasing, my original question is still:

I have a ListView and I'm using an ImageList to place one-of-six images in the first column, indicating a row's 'status'. I already have WM_NOTIFY in place to toggle status images via $NM_CLICK or $NM_DBLCLK, to modify text color of individual subitems using $NM_CUSTOMDRAW, and to redraw grid lines using $LVN_ENDSCROLL and WinAPI_InvalidateRect($hLV).

I can enable $LVS_EX_INFOTIP which will display an empty infotip when you hover over an image, but I can't find documetation as to how to populate that infotip. Could someone point me to what else I might load into my WM_NOTIFY, or how/what/where else I might add code to use the $LVS_EX_INFOTIP state of ListView and set, by row, the infotip for an image?

Hmm... I see that $LVS_EX_INFOTIP is still declared in the include files for AutoIT version 3.3.0.0, but I see no mention of it in the help file. Is this ListView state on the way to the scrap pile?

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0