Sign in to follow this  
Followers 0
Shimgreen

User Created Version of Telnet

6 posts in this topic

Hey guys, there is a lot of good scripters here on this site and i was wondering if maybe at one time

someone created and has there own User Created Version of Telnet that they would share, it would be much appreciated if i could find one.

Share this post


Link to post
Share on other sites



IMO - a Telnet script can't be created with Microsoft Telnet (I'm not 100% sure because I'm not an expert in Console operations).

The only way I found so far is to use a 3rd party ActiveX/COM Telnet. I tried to find a freeware one but I failed so I had to use a trial version for testing and after that to buy a developer license ;)


SNMP_UDF ... for SNMPv1 and v2c so far, GetBulk and a new example script

wannabe "Unbeatable" Tic-Tac-Toe

Paper-Scissor-Rock ... try to beat it anyway :)

Share this post


Link to post
Share on other sites

well... ty anyways

Share this post


Link to post
Share on other sites

Here

What you may be looking for?

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Yes it helps thank you.

but now I got a new qusetion...

for some reason all hell seems to break loose out on my script im trying to make.

I keep getting error after error and I dont see how its happening maybe someone can help spot it out?

#include <GUIConstants.au3>
#include <file.au3>

Global $i, $rcount, $time, $main, $acc, $data, $send, $123, $recv, $file, $string

GUICreate("Shimgreen's QuickStart v1.5", 530, 276)
GUICtrlCreateLabel ("Shimgreen's QuickStart v1.5", 17, 263, 200, 200)
$Button_1 = GUICtrlCreateButton ("Room 1", 75, 25, 75, 25, $BS_CENTER)
$chainroom1="208.109.208.136"
GUICtrlCreateLabel("Command log", 100, 100, 90, 30)
$edit = GUICtrlCreateEdit("", 10, 50, 190, 150)
$port = 1849
$information = information
GUISetState ()

 
 $msg = 0
  While $msg <> $GUI_EVENT_CLOSE 
    $msg = GUIGetMsg()

 select
Case $msg = $Button_1

     TCPStartUp()
Do
       $mainsocket = TCPConnect($chainroom1, $port)
Untill $mainsocket <> -1
sleep(400)
       TCPSend($mainsocket, $Reset)

   TCPShutDown()

endselect
wend

It keeps saying that $information = information

has a missing separator charecter after keyword.

Then I take it out and it says Wend has no while...

then it says Do has no untill....

I just dont get it because it seems like it shouldnt be doing that.

Edited by Shimgreen

Share this post


Link to post
Share on other sites

Everytime you assign a string value to a variable, it has to be enclosed within double quotes or single quotes.

$information = "information"

SNMP_UDF ... for SNMPv1 and v2c so far, GetBulk and a new example script

wannabe "Unbeatable" Tic-Tac-Toe

Paper-Scissor-Rock ... try to beat it anyway :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0