Jump to content
Sign in to follow this  
Glyph

Problem with options

Recommended Posts

Glyph

will send shift fine, but screws up caps.

I need a way of using both without screwing the other up!

Anybody have any ideas or a workaround, I can't seem to find anything that works! -.-

Edited by Jon

tolle indicium

Share this post


Link to post
Share on other sites
Airwolf

Why do you need caps lock to work? You can just use Send("{SHIFTDOWN}") to hold down shift, then use Send("{SHIFTUP}") when you're done. Also, see the help file entry for Send():

You can set SendCapslockMode to make CAPS LOCK disabled at the start of a Send operation and restored upon completion.

However, if a user is holding down the Shift key when a Send function begins, text may be sent in uppercase.

One workaround is to Send("{SHIFTDOWN}{SHIFTUP}") before the other Send operations.

Certain keyboard as the Czech one send different characters when using the Shift Key or being in CAPS LOCK enabled and sending a char. Due to the send AutoIt implementation the CAPS LOCKed char will be sent as Shifted one so it will not work.


Certifications: A+, Network+, Security+, Linux+, LPIC-1, MCSA | Languages: AutoIt, C, SQL, .NETBooks: AutoIt v3: Your Quick Guide - $7.99 - O'Reilly Media - September 2007-------->[u]AutoIt v3 Development - newbie to g33k[/u] - Coming Soon - Fate Publishing - Spring 2013UDF Libraries: SkypeCOM UDF Library | ADUC Computers OU Cleanup | Find PixelChecksumExamples: Skype COM Examples - Skype4COMLib Examples converted from VBS to AutoIt

Share this post


Link to post
Share on other sites
Glyph

Why do you need caps lock to work? You can just use Send("{SHIFTDOWN}") to hold down shift, then use Send("{SHIFTUP}") when you're done. Also, see the help file entry for Send():

Only problem with this is that it will call my hotkey, when I press the number.

If I send "shiftdown", "1", then "shiftup", it will not only do "!", but it will then call the function that I have binded to the number "1", so this is not a solution.

Thank you for the help though, I really appreciate the response.


tolle indicium

Share this post


Link to post
Share on other sites
AdmiralAlkex

Only problem with this is that it will call my hotkey, when I press the number.

If I send "shiftdown", "1", then "shiftup", it will not only do "!", but it will then call the function that I have binded to the number "1", so this is not a solution.

Thank you for the help though, I really appreciate the response.

Why not unset the HotKeySet() before Send() and then "reset" it again? ;)

Share this post


Link to post
Share on other sites
Glyph

Fixed it!

What I did was I added "shiftup", before the caps lock hotkey!

Thanks for your help everyone, much appreciated!

also removed the capslockmode option, and only used attach.

Edited by BackStabbed

tolle indicium

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×