Jump to content
Sign in to follow this  
mumdigau

How to change the Defaults for AutoIt3Wrapper

Recommended Posts

mumdigau

Hi,

I used AutoIt3Wrapper.ini.example which came with the SciTE installation to build my own ini-file in order to adjust the Defaults, i.e.

aut2exe=B

to switch the AutoIt3 version from production to beta. But when AutoIt3Wrapper_Gui comes up, still 'production' is preselected. I looked into Directives.au3 if that might be the culprit, but it contains comment lines only. So how do I change the Compiler Directives?

Many thanks for any help.

Best regards

mumdigau

Share this post


Link to post
Share on other sites
Jos

No need to "mess" with the INI file for this.

Use the proper F-Keys to select Production of Beta. See link in my sig for more info the the SciTE4AutoIt3 helpfile.

;)


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
mumdigau

No need to "mess" with the INI file for this.

Use the proper F-Keys to select Production of Beta. See link in my sig for more info the the SciTE4AutoIt3 helpfile.

;)

Thanks Jos for pointing to that explanation. That should solve the switch between production and beta. But there are two things I noticed:

1. When starting AutoIt3Wrapper_Gui (with commandline parameters /in "%l") the 'production' is always preselected as AutoIt version even when I run UpdateDefs.exe and switch to beta before.

2. HKCR\.au3 always points to AutoIt3ScriptBeta, so the context menu in Windows Explorer isn't changed from production to beta and vice versa.

Should those work (as expected by me), or is my (fresh) installation somehow messed up?

Regarding other AutoIt3Wrapper_Gui settings (e.g. compression level changed to 'highest') I still have to use AutoIt3Wrapper.ini, haven't I?

Best regards

mumdigau

Share this post


Link to post
Share on other sites
Jos

Updatedefs ONLY switches the definition files for SciTE to work with as only one set can be loaded at a given time. This does nothing for AutoIt3Wrapper.

As for the GUI. when it is started it doesn't care about Production or Bate as it only uses the Directive: "#AutoIt3Wrapper_Version=" to determine what version to use. It defaults to production but when the code contains "#AutoIt3Wrapper_Version=Beta" it will run the Beta version.

The HKCR\au3 should always point to Production unless you ran the ToggleAU3Beta script which I honestly think we should scrap but is there for people that want to manually switch between versions.

As to having to use the INI: You don;t need to use it for anything unless you want to tweak the AutoIt3Wrapper defaults but you better understand what you are doing or else you could screw up. the way it works is as follows:

  • AutoIt3Wrapper has is its own defaults
  • AutoIt3Wrapper in is read and will override any setting specified
  • Scriptname.au3.ini is read and will override any setting specified
  • The directives are read and will override any setting specified
All the GUI does is update Directives in the script.

Jos

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×