Sign in to follow this  
Followers 0
pixartist

connect to my routers cgi-bin?

4 posts in this topic

hi, i wanna write a script to control my router without using the webinterface. unfortunatly the "disconnect" button will link me to "/cgi-bin/dial?rc=@&A=H0&rd=status'". when i manually enter 192.168.0.1/cgi-bin/dial?rc=@&A=H0&rd=status' it says "not found" :/

how can i access that command manually?

Share this post


Link to post
Share on other sites



It's probably a security thing. It might not let your AutoIt program access the configuration because it doesn't show a major web browser client.

Share this post


Link to post
Share on other sites

hi, i wanna write a script to control my router without using the webinterface. unfortunatly the "disconnect" button will link me to "/cgi-bin/dial?rc=@&A=H0&rd=status'". when i manually enter 192.168.0.1/cgi-bin/dial?rc=@&A=H0&rd=status' it says "not found" :/

how can i access that command manually?

Does not getting the disconnect button to work mean you did get other functions to work? If so, post a short AutoIt snippet of how you got any of it working.

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

i had to add username:password@ip to make it work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0