Sign in to follow this  
Followers 0
Billy

Aut2Exe dies - Unable to execute upx.exe ...

4 posts in this topic

Windows XP, AutoIt 3.2.12.1

The problem is that when I compile an AutoIt script, I get the dialog:

Aut2Exe Error

Error: Unable to execute upx.exe to compress stub file.

This occurs running from the UI AND the command line. It was working but not any longer. Something in my environment must have changed but I have no idea what.

I have added AutoIt to my path AND AutoIt\Aut2Exe and still no go. I also ran the command line from the Aut2Exe directory and got the same result. I can only make it work right now using the /nopack switch.

Running UPX (version 3.1.0.0) "by hand" works.

Any ideas?

Share this post


Link to post
Share on other sites



I've gotten that error before. I don't know what causes it. I think other people have complained about it too...

I just hit compile a few times and one works eventually.

Share this post


Link to post
Share on other sites

Do you get this with the newest Beta? I'm fairly certain it's an issue with the latest release, but can be easily fixed by simply not using UPX.

http://www.autoitscript.com/forum/index.ph...st&p=559012

Last line of the post.


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0