Sign in to follow this  
Followers 0
Chris

No ControlXXX functions working at all (but same script runs fine on other XP boxes)

2 posts in this topic

Hi,

I'm trying to automate the install of a program which will be rolled out onto 150 laptops. I have a perfectly working au3 script which works fine on other XP boxes.

The problem is we have a new standard xp install which includes service pack 3.

None of the ControlXXX commands seem to work with it (eg ControlFocus,ControlSend, ControlCommand, ControlClick).

I don't know if service pack 3 is the problem. I've installed service pack 3 onto one of our old laptops and the script runs fine.

So I'm wondering if perhaps there is some system service which is needed for the Control based commands to work.

Can anybody tell me any system service, setting, or permission which could affect these Control based commands?

Our laptops are locked down to some extent so it's possible something is disabled.

Thanks

Share this post


Link to post
Share on other sites



I just thought I should add what I tried to do already:

- I checked the window matching was working. That all works fine.

- I was originally using a window ID like "[CLASS:Button; TEXT:No]" to select a control however

on the new system it didn't work. I thought perhaps matching by text is failing due to some locale or character set issue so I tried every other way of matching the control. eg CLASSNN, ID, etc. None of it worked.

- I thought perhaps the "Check" command was failing so I tried using Focus and Click. Neither worked.

- Finally I resorted to sending tabs, down, space, enter etc, which worked (but is a bit unreliable - sometimes the down seems to cause the radio box to change twice).

I'm thinking that either it is somehow failing to match the controls, or else it is finding them but failing to send a message.

I don't know much about windows APIs but I'm guessing it uses SendMessage or something like that.

If that's the case, is there any system setting which could cause SendMessage to fail?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0