Jump to content
Sign in to follow this  
Natas70

Extremely new noob, needing help

Recommended Posts

Natas70

ok, i am running on vista, with autoit v3, and i am trying to make an mtgo bot. I do have some visual basic experience as a hobbyist, so i am not in the industry. And i allready understand that this is an elementary problem compared to the complexity of what i am trying to do.

My first problem and question to the community is:

i am trying to get the program renamer.exe to start (which is the name of the launcher program for mtgo). if the script is in the same directory with the renamer program works. if it is even 1 level up, it gives me error pop up, not in autoit, but i am guessing from the mtgo program.

here is my run command

run ("Renamer.exe","C:\Program Files\Wizards of the Coast\Magic Online III\")

i have tried this also

run ("C:\Program Files\Wizards of the Coast\Magic Online III\Renamer.exe")

same result, works in same directory, but not anywhere else in my computer

here is a screenshot of the error

Posted Image

or if i don't get this error, it just doesn't load the program at all, and it continues to try to move mouse to click an imaginary launch button.

the directory is correct

thanx in advance, i really do understand that this is an elementary problem.

James

Share this post


Link to post
Share on other sites
UnknownWarrior

You know theres always the simple solution of it just MouseClicking to the program your trying to load xP

Share this post


Link to post
Share on other sites
AdmiralAlkex

@Natas70

It looks to me like you want to run renamer.exe from another directory and set the workingdir, correct? That would be something like:

("C:\Program Files\Wizards of the Coast\Magic Online III\Renamer.exe", "C:\Program Files\Wizards of the Coast\Magic Online III\")

@UnknownWarrior

That was the dumbest thing I have heard today, please think before you post. It would save you alot of embarrassment.

Share this post


Link to post
Share on other sites
Natas70

actually i would like my script to be in its own directory with other support files, like ini's and price lists. and run renamer which is the start exe file for the magic the gathering program.

as it is now, if the script is not in the renamer.exe folder, it fails to launch the program and continues to try to move the mouse and log in, or it gives me that error screenshot.

Share this post


Link to post
Share on other sites
Natas70

Did the code i posted not work? Then you need to explain more, in what folder is the script, where is the "renamer.exe", what errors do you get etc...

Sorry, i didn't try it until just now, i was just trying to clarify my problem for you. and yes it did work.

thank you. i tried the script from several locations and it worked great.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×