Sign in to follow this  
Followers 0
fielmann

Webbased AU3 Error 500 (#Include <Web.au3>)

14 posts in this topic

Hello webbased AutoIt friends

I need help :(

I can't use webbased autoit.

I've installed abyss webserver, configured *.au3 to C:\Programme\AutoIt3\AutoIt3.exe and started the webserver.

A simple test.html I can open with Internet Explorer window without problems.

When I try to open http://localhost/test.au3 it doesn't work :)

Instead of that I'll get back the folowing message:

"Error 500

Internal Server Error

Powered by Abyss Web Server X1

© Aprelium Technologies - 2001-2007"

Here is the content of test.au3:

#Include <Web.au3>
_StartWebApp()
echo("hello world")

Any ideas where the problem is? :mellow:

thx in advance

Share this post


Link to post
Share on other sites



echo() isn't an AutoIt command? Or am I misunderstanding?


[right]~What can I say, I'm a Simplistic person[/right]

Share this post


Link to post
Share on other sites

echo() isn't an AutoIt command? Or am I misunderstanding?

you can find echo in: #Include <Web.au3>)

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Post a screenshot of your autoit setup in the abyss control panel, ill compare it to mine.

EDIT::

Posted Image

Edited by AzKay

# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

you can find echo in: #Include <Web.au3>)

sorry for that. I just like to take out bugs by tarting at the simplest mistakes.


[right]~What can I say, I'm a Simplistic person[/right]

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

here is a picture my abyss-config:

Posted Image

thx in advance!

Edited by fielmann

Share this post


Link to post
Share on other sites

has anyone an idea what's wrong? :mellow:

Share this post


Link to post
Share on other sites

Show a screenshot of the actual config part for autoit. The one I posted.


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

Show a screenshot of the actual config part for autoit. The one I posted.

I've already posted it (see above) :)

Share this post


Link to post
Share on other sites

You didnt post the same page I posted.


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

try using FastCGI (Local - Pipes)

ok, where can I find Fast CGI ? :)

Share this post


Link to post
Share on other sites

You didnt post the same page I posted.

you are right! :)

here is the new picture to compare:

Posted Image

Share this post


Link to post
Share on other sites

Other than the /errorstdout, Ive not much idea.

Try setting the path to the autoit beta.


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0