Sign in to follow this  
Followers 0
DexterMorgan

_IE() Invisible?

4 posts in this topic

#1 ·  Posted (edited)

Well, I've been working on IE functions for a while now, Last week I started making the IE Invisible

like this

_Iecreate('',0,0)

Of course I Have the include and everything,

The problem is that it is invisible for me, but when I go on my other computer, it is not invisible..

I want to know if there is

1) An error code that can tell me if the window is visible or not

or

2) A code that can make it invisible..

I know this sounds very malicious :mellow: But it isn't...

Thank you for any help!

dsfjlsdlkfjklsdjflkjsdkljflksdjklflsdjfklsdjfklsjdklfjsdlfjdjsfjsldjfklsdjfklsdjflksjdlkfjsdljfsdkjflsdjflkjsdlkfjlksdjfkljdsklfjklsdjfkljsdlkfjdklsjfklsdjflksdjflksdjklfjsdlkjflksdjflsdjflkjsdlfjsdljfkldsjflksdjflkdsjflkjfkljsdklfjdklsjfsdjfls
dsfsdfsd
fsdfsd
fsd
fsdfsdfsdfsdf
sdfsd
fsdfsd
fsd
fsdfsdfsdf
sdfsd
fsdfsdfsd
f
dasdasdsa
das
ds
ad
sad
sa

Edited by DexterMorgan

code

Share this post


Link to post
Share on other sites



I have experienced the same thing with IE7.

Well, perhaps you are looking for:

_IEPropertyGet ( ByRef $o_object, $s_property )

Property:

"hwnd" Retrieves the handle of the Internet Explorer main window. Can be used in most AutoIt Win* functions.

You can get the handle of the IE window and then check if is visible with WinGetState. If it is, hide it like any other window with WinSetState().

Share this post


Link to post
Share on other sites

I have experienced the same thing with IE7.

Well, perhaps you are looking for:

You can get the handle of the IE window and then check if is visible with WinGetState. If it is, hide it like any other window with WinSetState().

ahh, thanks :mellow:

code

Share this post


Link to post
Share on other sites

Only place I've seen trouble is on Vista with UAC... if that is your trouble, see the docs and use #RequireAdmin

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0