Sign in to follow this  
Followers 0
jackrabbit

Syntax highlight probelm with normal user account (Solved)

7 posts in this topic

#1 ·  Posted (edited)

Dear all,

I am using the latest version of SciTE,

Version 1.77

Oct 23 2008 19:06:08

I found the syntax highlight only works under administrator account. It does not work under normal account user. Is this a bug or I need modify some settings?

Thanks.

Edited by jackrabbit

Share this post


Link to post
Share on other sites



this happens to me too : /

I just right click the SciTE icon and click "runas"

Thanks. So I am not crazy. :-)

I also know runas, but it is a pain to enter admin password every time. Is there some place to submit bug to the SciTE developers?

Share this post


Link to post
Share on other sites

Thanks. So I am not crazy. :-)

I also know runas, but it is a pain to enter admin password every time. Is there some place to submit bug to the SciTE developers?

Does anyone have workaround beside using runas?

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

It works fine for me on a limited user account in WinXP.

So lets check a couple of things:

- what OS are you using?

- How was SciTE installed?

- What is the content of the SciTEUSer properties file?

- What is the content of the SciTEGLobal properties file?

- What is the content of au3.proiperties?

- What is the content of au3.keywords.properties?

- What are the actual rights for the user to the SciTE program directory.

They can all be viewed via the Options menu.

By the way It does make things work a lot better when the USer does get write access to teh SciTE program directory and subdirectories. The Installler will update the security setting of the SciTE program directory give the Users group this access.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Jos helped me fixed the problem.

Basically under the limited user account, I can not access file au3.properties. I logged into Admin and give my limited user privilege for this file and then the syntax highlight works. If it still does not work, please give privilege for file au3.keywords.properties as well.

In SciTE, go to Options menu. If you can see these two files under this menu, then it should work. Otherwise, it will not work.

Thanks Jos for debugging this.

Share this post


Link to post
Share on other sites

Jos helped me fixed the problem.

Basically under the limited user account, I can not access file au3.properties. I logged into Admin and give my limited user privilege for this file and then the syntax highlight works. If it still does not work, please give privilege for file au3.keywords.properties as well.

In SciTE, go to Options menu. If you can see these two files under this menu, then it should work. Otherwise, it will not work.

Thanks Jos for debugging this.

I found the reason for this problem. updatedefs would create a new version of au3.properties in the @tempdir and then copied back to the original which would cause the security setting of the tempfile to be used and not allowing the limited Users group access to the file.

I have uploaded a new version of SciTE4Autoit3 installer that includes this fix.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0