Sign in to follow this  
Followers 0
hlmindustries

Having difficulties with keyboard shortcuts

15 posts in this topic

when I press shift+F1 (holding shift first) the SciTE function list should pop up, but it doesnt, I just recently installed autoit3 (the official release) then the SciTE4AutoIt3 from the sites download section... anyways I tried it directly after install... it didnt work, so I decided to restart my pc, but it still did not work, is there another way to do it than the keyboard? am I doing something wrong?

any and all help appreciated

Share this post


Link to post
Share on other sites



just press F1

Share this post


Link to post
Share on other sites

just press F1 does nothing... absolutely nothing

Share this post


Link to post
Share on other sites

try at the top of Scite click help then click help agian, that should bring it up without the hotkey, if it doesnt then you dont have the helpfile installed.

Share this post


Link to post
Share on other sites

well, I guess I dont have the helpfile installed, I reinstalled, but that did nothing, it is set to full install, but it still wont pull it up

is it my pc?

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

here i uploaded mine to 2shared,try putting it in your program files\autoit3 folder and see if that fixes it.

Edited by Rental

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

I aleady have autoit3.chm in my autoit3 folder...

I can open it and view new topics with no problem

EDIT: they are the same exact size also

Edited by hlmindustries

Share this post


Link to post
Share on other sites

You wouldn't have a popup blocker, or antivirus/antispyware software with that kind of function, or something like that installed, would you? (Not that I have tested this theory but it might make sense... For me the Shift-F1 function works just fine.

Another way would be to go to Tools > FunctionPopUp. Or alt+t, f. Or make a Windows shortcut to ...\SciTE\FuncPopUp\FuncPopUp.exe, and give that a Windows hotkey. Or probably a plethora of other workarounds.

I would at least at the very first test starting the FuncPopUp.exe manually to see if the program itself actually works on your machine. If not, then don't bother looking in Scite for a workaround but see why it doesn't work for itself. Again, anti-malware applications come to mind.


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

funcpopup.exe works fine... I try running it with all my antimalwae and antivirus software disabled... and it still wont work, when I go into tools... its not there!

im using SciTE Script Editor ("C:\Program Files\AutoIt3\SciTE\SciTE.exe")

edit: when I open funcpopup manually, everything is greyed out, and I cant move either of the scroll bars

edit2: at the bottom of it it says not an AutoIt3 file active(AU3)

edit3: edit2 fixed after I save a file

Edited by hlmindustries

Share this post


Link to post
Share on other sites

What is your exact operating system? (I mean like "Windows Vista 32 bits NL, service pack 1".) I heard of some issues with .chm files. Google for that + chm, maybe something will come up. Might be a longshot but is all I can at least think of.

Not that I'd know how that would remove the links to the helpfile from SciTE... Tried reinstalling it one time with the full packages to be absolutely sure?


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites

Windows XP Professional SP3 (not sure on bit type)

I got it fixed after I saved a file, thank you for all the assistance

Share this post


Link to post
Share on other sites

Windows XP Professional SP3 (not sure on bit type)

I got it fixed after I saved a file, thank you for all the assistance

LOL...helpfile works only when youre script is saved... :)


 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites

#14 ·  Posted (edited)

You do have an file open with an .au3 fileextension ?

Jos

Ops sorry for last reply this was for the last version of SciTE since...2months. now it works :)

Edited by FireFox

 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0