Sign in to follow this  
Followers 0
Wikipete

Help please. Autoit is different on this computer.

11 posts in this topic

Hi there.

I have been using AutoIt for about 2 years now and have never had any issues (like this one). I recently installed autoit on a new computer (running XP service pack 3) and found several differences from the one that I had been previously using on an XP service pack 2 computer.

I will highlight these differences below and I have found no reason why they should be different on my new machine than my old one.

1. I cannot create .au3 files. (every editable script appears as a .txt document which opens in word).

2. There is no (shell?!), I.E. when I right click on a blank area of my desktop and go to "New" no "Create new autoit file" option appears.

3. When I edit the scripts they are all in .txt documents and not in sciTE.

4. When I open sciTE the most recently built script appears, NOT a blank page.

5. There is no "compile" option on the left click drop down menu.

I have installed version 3.3.0.0 and the exact same things are happening.

Please help!

Thanks.


 Run (Brain.exe)
.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

@Wikipete

I think its not autoit problem with installtion... reinstall windows or install service pack 3 :)

Edited by FireFox

 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites

@Wikipete

Its not autoit problem... reinstall windows or install service pack 3 :)

Right... k. I will go elsewhere to get answers.

Thanks.


 Run (Brain.exe)
.

Share this post


Link to post
Share on other sites

Right... k. I will go elsewhere to get answers.

Thanks.

I would try simply uninstalling AutoIt and then reinstalling it. That can often cure many cases of oh shit what went wrong with that. If that doesn't help feel free to post in here again for more trouble shooting.

Share this post


Link to post
Share on other sites

Heh, I actually know the answer to your problems... Same thing happened on my schools laptop when I put my AutoIt folder on it and tried coding... What you must do:

1. Right click the .txt file and click 'Open With'

2. Browse for AU3 editable script.

3. Select it and check the checkbox that asks: "Always use the selected program for this file type" (somethin like that)

There ya go :)

Share this post


Link to post
Share on other sites

... 1. I cannot create .au3 files. (every editable script appears as a .txt document which opens in word). ...

".txt" files open in notepad by default, so something has been changed in the computer that is giving you problems.

When you say "appears as a .txt document" - do you see a file extension of txt on the end of an au3 file???

Please do not be insulted by the verbose info below. You may already know all of the stuff mentioned below and all I did was waste my time and some electrons.

Right mouse click on an empty space on the desktop of the XP SP3 computer

Select New > Text Document

Rename this newly created file to 1.au3

Did the renaming process warn you with?

---------------------------

Rename

---------------------------

If you change a file name extension, the file may become unusable.

Are you sure you want to change it?

---------------------------

Yes No

---------------------------

If you did not get that warning, then that new file on your desktop is probably named:

1.au3.txt

Go to Start > Run

Type "control folders" and press enter

Once the Folder Options applet opens

Select the tab named "View"

Uncheck "Hide extensions for known file types"

Press "OK" to exit the applet.

If this was the problem, then you should be able to rename that new file to 1.au3

As far as the context menu info now appearing [i.E. when I right click on a blank area of my desktop and go to "New" no "Create new autoit file" option appears.] Was AutoIt installed while admin, but being used as some lower level of user? The context menu should still appear for a non-admin "user", but sometimes over zealous anti-virus and anti-malware software "protects" a non-admin "user" from changes to context menus.


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

... or install service pack 3 :)

The computer that works well for the OP has service pack 2.

The computer that seems to be broken for the OP has service pack 3.

Are you suggesting installing service pack 3 on the computer that already has SP3?


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

Heh, I actually know the answer to your problems... Same thing happened on my schools laptop when I put my AutoIt folder on it and tried coding... What you must do:

1. Right click the .txt file and click 'Open With'

2. Browse for AU3 editable script.

3. Select it and check the checkbox that asks: "Always use the selected program for this file type" (somethin like that)

There ya go :)

So you are telling the operating system to always open txt files with one au3 file?

Please elaborate.


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

The context menu entries are created in the HKLM registry entries so you need to be admin to install AutoIt complete else no context menu entries may be created.

:)

Share this post


Link to post
Share on other sites

The context menu entries are created in the HKLM registry entries so you need to be admin to install AutoIt complete else no context menu entries may be created.

:)

I thought about this too and was pleased to learn that the install halts if you are not admin (at least on XP Pro):

---------------------------

AutoIt v3.3.0.0 Setup

---------------------------

Error! You must have administrator rights to install this package.

---------------------------

OK

---------------------------

So I logged in as admin, did the default install (which included an uninstall of the older release of AutoIt) and of course the context menu was there as expected.

Logging back in as a non-admin user gave me the context menu entry as expected.

I'm a bit confused by the OP's statement here:

3. When I edit the scripts they are all in .txt documents and not in sciTE

I'm not sure if these are scripts that came over from the SP2 computer or ones that the OP attempted to make fresh on the SP3 computer. If "fresh", then it may just be the file extension issue that I was rambling on about above.

@OP,

4. When I open sciTE the most recently built script appears, NOT a blank page.

This is the default method of operation for the "lite version" of SciTE (the version that comes with the AutoIt installation). If you install the "full version", that behavior continues. If your SP2 computer did not do this, then something was changed on that computer.

5. There is no "compile" option on the left click drop down menu.

I'm guessing that you meant the right click explorer context menus. Those menus are based on the file extension of the file that was "right clicked on".... so, if the file extension is an invisible .txt - you should not see the options to compile.

~hope this helps~


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

Just a simple question: When the AutoIT installation program asked you what you wanted to do when you double clicked on a AU3 file, what was your answer?

This may be the root cause of your issues.

Comment: Your other file associations seem to be out of whack too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0