Sign in to follow this  
Followers 0
Kris123

Auto IT tool stops execution

3 posts in this topic

Hi all,

Here i would like to tell the problem of Auto IT when interacting with Win32 DLLs.

The problem is : i am trying to call a DLL in my script, which internally interacts with 3 more DLLs.

Those 3 DLLs need to be copied in windows/System32. When i try to call an API in the DLL (through the script), Auto IT is crashing and stopped execution.

Please find the bellow attached BMP file.

Please do the needful. Thanks in advance.

post-42872-1232431969_thumb.jpg

Share this post


Link to post
Share on other sites



All you need is to execute a command from a DLL? If so then you don't have to worry about anything, what the dll does. That is how you can support multiple languages.

Anyways, that BMP doesn't tell us anything about what could possibly be causing your AutoIT to crash


0x576520616C6C206469652C206C697665206C69666520617320696620796F75207765726520696E20746865206C617374207365636F6E642E

Share this post


Link to post
Share on other sites

Please find the script i am trying to run.

$dllhandle = DllOpen(@ScriptDir & "\MonitorTestingPlugin32.dll")

MsgBox(0, "", $dllhandle)

$AddResult = DllCall($dllhandle, "long", "Monitor_Init")

MsgBox(0, "", $AddResult[0])

$AddResult1 = DllCall($dllhandle, "long", "Monitor_SetProperty", "long", 16, "long", 100)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0