Sign in to follow this  
Followers 0
Suirad

my antivirus kills upx compression when i compile

7 posts in this topic

#1 ·  Posted (edited)

i currently use Avast antivirus, its been working great untill it started flagging my upx compile with autoit :)

if i hit the "x" to get the compile to finish, it still give me errors and my program wont run.

it says something about: Win32:Poison-KP [Trj]

i cant manage to get it to skip it

any help?

edit: it never did this before, i just started today, and it makes me sad :lmao:

Edited by Suirad

Share this post


Link to post
Share on other sites



anything at all?

Share this post


Link to post
Share on other sites

So don't use UPX. It's a public/free packer which is used by malicious software as well. Avast is obviously to lazy to single out the malicious programs and just flag anything UPX.

#AutoIt3Wrapper_UseUpx=n

Put that at the top of your script.


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

My AV (BitDefender) also flags a few compiles, whilst UPXing, not all though, strangely enough.

I just disable my AV on the rare occasion.

Share this post


Link to post
Share on other sites

My AV (BitDefender) also flags a few compiles, whilst UPXing, not all though, strangely enough.

I just disable my AV on the rare occasion.

Brilliant... you know the issue, see there's a solution, but disable your protection against the world.

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Tinfoil hat wearer by any chance?

For the whole 3 seconds it takes to UPX, that's fine by me. My AV is neither protection against the world nor a necessity. Purely piece of mind for when one of my kids decides to tinker on daddies laptop.

Share this post


Link to post
Share on other sites

i currently use Avast antivirus, its been working great untill it started flagging my upx compile with autoit :lmao:

if i hit the "x" to get the compile to finish, it still give me errors and my program wont run.

it says something about: Win32:Poison-KP [Trj]

i cant manage to get it to skip it

any help?

edit: it never did this before, i just started today, and it makes me sad :think:

@dariuS, :)

Did you ever think that you might already be infected with malware that injects particular binaries

before bringing this gripe here?

It is most likely as SmOke_N says, in that Avast is just getting lazy with its heuristic's,

or its recognition database is flawed. In which case send the binary to Avast!

This topic has been quite a popular one over the years, try typing upx into the search feature!

You will find that using any sort of packer is a double edged sword, but most of the time an Av

flag is not an accurate representation of the packer or the program it has been applied to.

bored yet? < o_O >

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0