Sign in to follow this  
Followers 0
etfaker

right click -> no autoit

12 posts in this topic

#1 ·  Posted (edited)

hello.. i just installed autoit on my vista and dont see the normal autoit stuff (compile script,run script,.. ) if i right click a .au3

anyone knows why?

Edited by etfaker

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

did you use the installer or the zip file? You could go to folder options>file types>.au3 in explorer and see if .au3 is registered and what commands are there (if any). The installer version should add the extensions automatically if you have rights to the Hkey_classes_Root branch of the registry

Edited by Varian

Share this post


Link to post
Share on other sites

think i used the installer and not the zip.. and i have UAC disabled..

and where are these options..

on folder options there is nothing called "file types" or similar?

Share this post


Link to post
Share on other sites

i just reinstalled everything.. autoit + beta .. stil nothing in cotnext menu.. also wenn openening a .au3 (which i set for editing the script) it tells me .au3 is not associated with any programm. I manually changed oen it with scite..

plz can´t anyone help me? every script i try to compile doesnt work.. windows vista 64bit.. anyone maybe ?!

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

i just reinstalled everything.. autoit + beta .. stil nothing in cotnext menu.. also wenn openening a .au3 (which i set for editing the script) it tells me .au3 is not associated with any programm. I manually changed oen it with scite..

plz can´t anyone help me? every script i try to compile doesnt work.. windows vista 64bit.. anyone maybe ?!

What is shown for properties of .au3 file (right click -> Properties)?

edit:

If everything is written to registry as it should, in properties you should see that it's:

Type of file: AutoIt v3 Script (.au3)

Opens with: AutoIt v3 Script

Do this regardless of what you have done previously:

Click Change... and then choose AutoIt v3 Script /AutoIt Team/ (browse if you have to locate it) and click OK (important!).

That should do it.

If not it's a registry problem.

Edited by trancexx

♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites

What is shown for properties of .au3 file (right click -> Properties)?

edit:

If everything is written to registry as it should, in properties you should see that it's:

Type of file: AutoIt v3 Script (.au3)

Opens with: AutoIt v3 Script

Do this regardless of what you have done previously:

Click Change... and then choose AutoIt v3 Script /AutoIt Team/ (browse if you have to locate it) and click OK (important!).

That should do it.

If not it's a registry problem.

Opens with: Unknown application

how to fix it? :)

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Opens with: Unknown application

how to fix it? :)

Didn't I explain? Here again:

Click Change... and then choose AutoIt v3 Script /AutoIt Team/ (browse if you have to locate it) and click OK (important!).

AutoIt3.exe (you need to find this when click Browse) is located in \Program Files\AutoIt3 if you haven't changed that when installing.

Edited by trancexx

♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites

type of file: AU3 File (.au3)

opens with: AutoIt v3 Script

still i dont have compile on context menu and every program i try to compile doesnt work :)

Share this post


Link to post
Share on other sites

type of file: AU3 File (.au3)

opens with: AutoIt v3 Script

still i dont have compile on context menu and every program i try to compile doesnt work :)

That's a huge progress. It means that it's written to registry.

Now do it one more time (post 5). You don't need to browse now. Just click OK (If it's AutoIt v3 Script).

The change should be instant, desktop refreshed, and everything should work.


♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

what u mean with do it again? I should change the association again? to the same .exe? :)

@edit:

if yes.. i did.. it refreshed but still no compile in context (but edit & open)

Edited by etfaker

Share this post


Link to post
Share on other sites

what u mean with do it again? I should change the association again? to the same .exe? :)

This is joke, right?

♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

u said post 5

set the association of .au3 files with autoitv3.exe

and what did i wrote? the same.. so where is the joke ?!

and no it doesnt work as i already wrote...

Edited by etfaker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0