Jump to content
Sign in to follow this  

How do I...extract SQLite table field names on empty table?

Recommended Posts


I'm using the _SQLite UDFs and I have a database created with a empty table defined. Here is my query code:

$iResult = _SQLite_GetTable2d (-1, $sSQL, $aResult, $iRows, $iCols)

When I run a query on an 1 record table I get back

$iResult = 0

$iRows = 1

$iCols = 29

When I run the same query on a empty table I get

$iResult = 0

$iRows = 0

$iCols = 0

I'm getting back a completely empty $aResult. I was expecting Rows = 0 and Cols = 29 (containing the field names).

How do you extract field names from an empty table? Is this a bug or the expected reaction (I'm voting bug).

EDIT: I played with the sqlite.au3 file....looks like SQLite is returning back 0 columns so it doesn't look like a issue specifically with the UDF.


Edited by sshrum

Sean Shrum :: http://www.shrum.net

All my published AU3-based apps and utilities

'Make it idiot-proof, and someone will make a better idiot'


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.