Jump to content
Sign in to follow this  
iLoveAU3

What's wrong with this code?

Recommended Posts

iLoveAU3

$hWnd = WinGetTitle('[active]')
WinMenuSelectItem($hWnd, '', '&Tools', 'User CallTip Entries')
WinMenuSelectItem($hWnd, '', '&Search', '&Go To')oÝ÷ Ú·¬º[ZºÚ"µÍÝÐÎÌLÔÙÜ[H[ÉÌLÐ]]Ò]ÉÌLÔØÚUIÌLÜØÚ]K^H  ][ÝÐÎÌLÔÙÜ[H[ÉÌLÐ]]Ò]ÉÌLÔØÚUIÌLØIÌLØ]LËÙØ[ËI][ÝÂÉÝÌMÎ]]Ò]ÕÜ[ÚYÝÑ^]ÛÙN[YNKL
ÉÝÌMÎ]]ÒUË^H[YÎÝÑ^]ÛÙN[YNÍÍBÉÝÌMÎ]]Ò]ÕÜ[ÚYÝÑ^]ÛÙN[YNKLLÉÝÌMÎ]]Ò]ÕÜ[ÚYÝÑ^]ÛÙN[YNKBÉÝÌMÎÈ]]Ò]ÕÜ[ÚYÝÑ^]ÛÙN[YN
Í

lol?!

Share this post


Link to post
Share on other sites
Authenticity

It's because this menu sub item invokes an au3 file an so the wrapper need to close yours one? if you compile your source it won't do this behavior.

Edit: ...and actually it's '&Go to...'

Edited by Authenticity

Share this post


Link to post
Share on other sites
cmattb

nothing that I see. Are you making sure that the window you want is active as soon as the script starts? if your just running the script from the editor, then the edit is the active window. Try adding a sleep(5000) to the beginning to give yourself 5 seconds to change to the window you want.

Share this post


Link to post
Share on other sites
iLoveAU3

yes, this script is running directly from editor. suprising, compiled script does not behave this way :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.