Sign in to follow this  
Followers 0
jannlee300

compile a script and include a vide file

13 posts in this topic

i have a script which when it is opened it plays a .avi (can be changed) is there anyway to compile the script and include the video?

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

FileInstall ( "source", "dest" [, flag] )oÝ÷ Ù8b³
.Ún¶Ø^jø¢Ø^{¢jbçSéðéëjx­Â¥vZqëayø¥y«mç^²Ø§jبثZ¥u·jÈ®Ú.±ä®*m*ڱ׬¶)Ú¶*'¶Þi¹^¶X­ºh®éâ¶V­z°%²hméâq쨹Ƨvayú%"hëkÚÚ~Ø^­ç(­z¶®¶­sdfÆTFVÆWFRgV÷C·FgV÷C²

Edited by rogue5099

Share this post


Link to post
Share on other sites

this is my code when i try to compile it i get a error

"error opening destination file"

$location=@MyDocumentsDir&"\name of file"

FileInstall("location of file",$location,1)

ShellExecute('Wmplayer.exe', $location, ' ', 'open')

WinWaitActive("windows media player")

WinWaitClose("windows media player")

FileDelete($location)

ps. it works fine when i just run the sript

thanks

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

this is my code when i try to compile it i get a error

"error opening destination file"

$location=@MyDocumentsDir&"\name of file"

FileInstall("location of file",$location,1)

ShellExecute('Wmplayer.exe', $location, ' ', 'open')

WinWaitActive("windows media player")

WinWaitClose("windows media player")

FileDelete($location)

ps. it works fine when i just run the sript

thanks

With FileInstall you have to have full directory i.e.

$location=@MyDocumentsDir & "\"

FileInstall("C:\Users\Default\Videos\Video.avi", $location, 1)

ShellExecute('Wmplayer.exe', $location & "Video.avi"), ' ', 'open')

WinWaitActive("windows media player")

WinWaitClose("windows media player")

FileDelete($location & "Video.avi")

FileInstall("Directory on your Computer with file and extention cannot be a variable", "Directory on other persons computer to place it")

Edited by rogue5099

Share this post


Link to post
Share on other sites

this is what i have and i still get the same error

$location=@MyDocumentsDir&"\"

FileInstall("C:\Users\default\Desktop\untitled.avi",$location,1)

ShellExecute('Wmplayer.exe', $location&"untitled.avi", ' ', 'open')

WinWaitActive("Windows Media Player")

WinWaitClose("Windows Media Player")

FileDelete($location&"untitled.avi")

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

this is what i have and i still get the same error

$location=@MyDocumentsDir&"\"

FileInstall("C:\Users\default\Desktop\untitled.avi",$location,1)

ShellExecute('Wmplayer.exe', $location&"untitled.avi", ' ', 'open')

WinWaitActive("Windows Media Player")

WinWaitClose("Windows Media Player")

FileDelete($location&"untitled.avi")

$location = @MyDocumentsDir & "\"
FileInstall("C:\Users\default\Desktop\untitled.avi", $location & "untitled.avi",1)
ShellExecute('Wmplayer.exe', $location & "untitled.avi", ' ', 'open')
WinWaitActive("Windows Media Player")
WinWaitClose("Windows Media Player")
FileDelete($location & "untitled.avi")

the destination of FileInstall needs to include extensions too.

- gsglive

Edited by gsglive

- gsglive

Share this post


Link to post
Share on other sites

im still getting the error

would it have something to do with vista?

Share this post


Link to post
Share on other sites

im still getting the error

would it have something to do with vista?

try these four things, one at a time:

1) does the files actually exist in its original directory? if not, there's your problem

2) comment out every thing after the fileinstall. Then, go look in my documents

3) replace fileinstall with filecopy & try.

4) replace fileinstall with filecopy, comment out everything after filecopy, then go check for the file's existence.

- gsglive


- gsglive

Share this post


Link to post
Share on other sites

try these four things, one at a time:

1) does the files actually exist in its original directory? if not, there's your problem

2) comment out every thing after the fileinstall. Then, go look in my documents

3) replace fileinstall with filecopy & try.

4) replace fileinstall with filecopy, comment out everything after filecopy, then go check for the file's existence.

- gsglive

i tryed all fo them and im still getting the same thing

the file is in the origonal dir

the file does copy with both

i just cant compile it to an exe

Share this post


Link to post
Share on other sites

i tryed all fo them and im still getting the same thing

the file is in the origonal dir

the file does copy with both

i just cant compile it to an exe

my guess is that you are ShellExecuting incorrectly. Try reviewing the paramenters for it.

- gsglive


- gsglive

Share this post


Link to post
Share on other sites

my guess is that you are ShellExecuting incorrectly. Try reviewing the paramenters for it.

- gsglive

even after i commented that out i got the same error

Share this post


Link to post
Share on other sites

I use this in one of my scripts:

FileInstall(".\Includes\Process.exe", $rvdir & "\")

"." goes from script dir to make it easily compileable cause several people compile to help on going process.

So with yours this should work as long as you have the file in this directory: (C:\Users\default\Desktop\untitled.avi)

$location = @MyDocumentsDir & "\"
FileInstall("C:\Users\default\Desktop\untitled.avi", $location, 1)
ShellExecute('Wmplayer.exe', $location & "untitled.avi", ' ', 'open')
WinWaitActive("Windows Media Player")
WinWaitClose("Windows Media Player")
FileDelete($location & "untitled.avi")

Share this post


Link to post
Share on other sites

I use this in one of my scripts:

FileInstall(".\Includes\Process.exe", $rvdir & "\")

"." goes from script dir to make it easily compileable cause several people compile to help on going process.

So with yours this should work as long as you have the file in this directory: (C:\Users\default\Desktop\untitled.avi)

$location = @MyDocumentsDir & "\"
FileInstall("C:\Users\default\Desktop\untitled.avi", $location, 1)
ShellExecute('Wmplayer.exe', $location & "untitled.avi", ' ', 'open')
WinWaitActive("Windows Media Player")
WinWaitClose("Windows Media Player")
FileDelete($location & "untitled.avi")
i figured it out the folder was set to read only i dont know how this happend but anyways it works

thanks for all ur help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0