Jump to content
Sign in to follow this  
muhmuuh

need some help with firefox

Recommended Posts

muhmuuh

Hello!

I'm trying to automate some firefox processes. Can someone please help me set the default firefox page? I found that function _FFPrefSet ($ SName, $ vValue) in the FF.au3 but I could't find what are the possible values for $SName. Does someone now what value I should use? Is it there another way to set the default page?

I also have another question. Is it possible to automatically accept a ssl cer of a page and how? I searched through the FF.au3 but I didn't find anything that would help me.

Many thanks


I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

Share this post


Link to post
Share on other sites
Stilgar

Hello,

You can set the default startup page with this:

;...
_FFPrefSet("browser.startup.page",1)
_FFPrefSet("browser.startup.homepage","http://www.google.de")
; ...

There are all entries (same link like in the documentation):

about:config

What do you mean with "automatically accept a ssl cer"? This error page about unsecure certs?

Share this post


Link to post
Share on other sites
muhmuuh

_FFPrefGet ==> No match: $sName: browser.startup.page

I guess I'm doing something wrong. Would you please give me a hint where I might do it wrong?

Also, can I do it using COM objects? And if yes, what should I use for classname for the ObjCreate function as

$oIE = ObjCreate("Mozilla.Browser.1")
didn't work

Thanks again


I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

Share this post


Link to post
Share on other sites
Stilgar

This means that there is no entry "browser.startup.page" in your current config. The _FFPrefSet doesn't create new entries it only changing existing ones.

So if you manually change your startup-page in your preferences then _FFPrefSet works.

You can check this if you open the page about:config and set the filter to browser.startup

For FireFox isn't a com interface available (only an old ActiveX for FF 1.5)

Stilgar

Share this post


Link to post
Share on other sites
muhmuuh

I manually changed my default page to google.bg

These are the values I got from about:config

browser.startup.homepage; google.bg

browser.startup.homepage_override.mstone; rv:1.9.0.5

browser.startup.page; 1

and I still get that error for _FFPrefSet

p.s. and yes, for "automatically accept a ssl cer" I mean the error page that appears about unsecure certs


I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

Share this post


Link to post
Share on other sites
Stilgar

Some questions:

- Can you try the latest version of the FF.au3, please (I've uploaded it some minutes ago)

- Can you show me the full log please?

I have no idea how can you disable this security check.

Share this post


Link to post
Share on other sites
muhmuuh

#include <FF.au3>
$ww= _FFStart("google.bg")

_FFPrefSet("browser.startup.page",1)
_FFPrefSet("browser.startup.homepage","levski.bg")

__FFStartProcess: ""C:\Program Files\Mozilla Firefox\firefox.exe" -new-window "http://google.bg"  -repl 4242 
_FFConnect: OS: WIN_XP WIN32_NT 2600 Service Pack 2
_FFConnect: AutoIt: 3.2.10.0
_FFConnect: FF.au3: 0.5.0.1b-4
_FFConnect: IP: 127.0.0.1
_FFConnect: Port:   4242
_FFConnect: Delay:  2ms
_FFConnect ==> Timeout: TCPConnect Error: 10061
_FFConnect ==> General Error: Timeout: Can not connect to FireFox/MozRepl on: 127.0.0.1:4242
__FFSend ==> Socket Error
__FFSend ==> Socket Error
_FFPrefGet ==> No match: $sName: browser.startup.page
_FFPrefSet ==> No match: $sName: browser.startup.page
__FFSend ==> Socket Error
__FFSend ==> Socket Error
_FFPrefGet ==> No match: $sName: browser.startup.homepage
_FFPrefSet ==> No match: $sName: browser.startup.homepage
+>22:16:46 AutoIT3.exe ended.rc:0
>Exit code: 0   Time: 64.714

I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

Share this post


Link to post
Share on other sites
Stilgar

Ok, it looks like you haven't MozRepl (FireFox-AddOn) installed.

Edited by Stilgar

Share this post


Link to post
Share on other sites
muhmuuh

thank you very much for spending time to help me

it works now :D

i wish you all the best mate


I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.