Jump to content
Sign in to follow this  
victorawesome

Running AutoIt script remotely

Recommended Posts

victorawesome

Hi

I am trying to use an AutoIt script to automate some tasks on a Windows box. The tasks involve opening up a program and compiling some code and changing some configurations.

I have the script running as a service (Q4 from the FAQs)

From a Linux box I am trying to start the service by sshing into the Windows box (has ssh-cygwin server on it) and running "net start service_name".

I am getting this error

Administrator@CGYVMSRV03 ~

$ net start service_name

System error 5 has occurred.

Access is denied.

I am logged in as administrator so I figure I should have permission to do anything I want.

I have the service set to Logon as: Local System Account (with a check mark on "Allow service to interact with desktop")

Can someone tell me if what I'm trying to do is possible (since I am trying to start the service without a graphic interface) or if there is a better way to do this?

Thanks in advance.

Vic

Share this post


Link to post
Share on other sites
victorawesome

I'm not sure as this is really an AutoIt related issue?

Sorry, it's not really an Autoit issue ... I'm not sure where else I could ask a question and I'm just wondering if anyone has a better solution for me. I have read about psexec but that won't work for me because I'm using a Linux box.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.