Jump to content
Sign in to follow this  
dreamzboy

$SS_CENTER - Error?

Recommended Posts

dreamzboy

Please forgive me if this has been discussed.

My program has been running fine until I downloaded the latest Autoit from this site. After compiling and trying to run it, an error shows up in my code. :D

Here's my code:

GUICtrlCreateTab(40, 50, 310, 300)
GUICtrlCreateTabItem("Microsoft")
GUICtrlCreateLabel("Version 2.7", 0, 326, 390, 20, $SS_CENTER)
GUICtrlSetColor(-1, 0x0000ff)

The error is shown:

D:\My Documents\Scripts\Robo_Quik 2.7.au3 (30) : ==> Variable used without being declared.:
GUICtrlCreateLabel("Version 2.7", 0, 326, 390, 20, $SS_CENTER)
GUICtrlCreateLabel("Version 2.7", 0, 326, 390, 20, ^ ERROR
>Exit code: 1   Time: 0.412

What did I do? Thanks a bunch for your assistance!

Share this post


Link to post
Share on other sites
picaxe

#include <StaticConstants.au3>

Share this post


Link to post
Share on other sites
dreamzboy

Aahh! This is new. Thanks Picaxe for your quick assistance. I'm now a happy man. :D

Share this post


Link to post
Share on other sites
picaxe

Aahh! This is new. Thanks Picaxe for your quick assistance. I'm now a happy man. :D

Your welcome, there's some utilities in the examples forum to autoadd include constants. I have a shortcut to the AutoIt Includes folder on on desktop that I can use the right click search, containing text option to find which include is required.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×