Jump to content
Sign in to follow this  
Aeterna

Script stalling on _IEFormsubmit ?

Recommended Posts

Aeterna

I'm submitting a form with my script, logging in to all other forms fine, but on one, after I submit the form:

_IEFormSubmit($oForm) the script appears to just die. The script should end this loop and navigate to another page on the next loop but it just sits on the next page after the form was submitted.

I've tried _IELoadWait, tried setting a timeout, tried looping to do an action if the URL matched that page's URL..... nothing works. The button has no name, so I had to use formsubmit (unless theres another way to press that button?)

Has anybody had this problem before?

Share this post


Link to post
Share on other sites
DaleHohm

Please read the Remarks for _IEFormSubmit in the helpfile. Set $f_wait to 0 and then use _IELoadWait.

There are other ways to press the button, like _IEFormElementGetCollection with an index and _IEAction, click

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
Aeterna

Please read the Remarks for _IEFormSubmit in the helpfile. Set $f_wait to 0 and then use _IELoadWait.

There are other ways to press the button, like _IEFormElementGetCollection with an index and _IEAction, click

Dale

Thanks that was killiing me for hours!

Share this post


Link to post
Share on other sites
DaleHohm

Amazing what you'll find in the helpfile isn't it ^_^


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.