Jump to content
Sign in to follow this  
Popeye1

Autoit scripts not working on my vista laptop.

Recommended Posts

Popeye1

For some reason autoit scripts don't work on my vista laptop, I run them but nothing happens. I've heard of this happening to someone else aswell.

I have an online game running and the script should be clicking stuff in the game window, the game window is selected but nothing happens. I'm sure there's a simple fix to this, a setting on my machine must be wrong or something.

Share this post


Link to post
Share on other sites
walle

For some reason autoit scripts don't work on my vista laptop, I run them but nothing happens. I've heard of this happening to someone else aswell.

I have an online game running and the script should be clicking stuff in the game window, the game window is selected but nothing happens. I'm sure there's a simple fix to this, a setting on my machine must be wrong or something.

Add #RequireAdmin

"This function was primarily aimed at allowing AutoIt scripts to work correctly with Windows Vista User Account Control (UAC) (However, will also work on Windows 2000 and Windows XP)."

Share this post


Link to post
Share on other sites
Popeye1

Add #RequireAdmin

"This function was primarily aimed at allowing AutoIt scripts to work correctly with Windows Vista User Account Control (UAC) (However, will also work on Windows 2000 and Windows XP)."

Is there a way to just turn off windows vista user account control? I don't need it, I have other vista machines and scripts work fine on those.

Share this post


Link to post
Share on other sites
DCCD

Disable UAC

C:\Windows\System32\cmd.exe /k %windir%\System32\reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f

Enable UAC

C:\Windows\System32\cmd.exe /k %windir%\System32\reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 1 /f

After you enable or disable UAC, you will have to reboot your computer for the changes to take effect.

You can also enable or disable this from the Control Panel if you choose Link

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×