Jump to content
Sign in to follow this  
n8gk

"Weird Characters" Problem

Recommended Posts

n8gk

Hello,

I have a script that scrape some usernames from a webpage. But some of them have weird characters like:

ÐJMPA-$ERGiO

ÐJANG

ðúlí©íóúskíðð

_FFOpenURL("hxxp://www.webpage.com/members/" & _ArrayPop($Users) &  ".aspx")

These are my log outputs:

_FFOpenURL: http://www.webpage.com/members/ÐJMPA-$ERGiO.aspx
__FFSend: try{window.content.document.location.href="http://www.webpage.com/members/ÐJMPA-$ERGiO.aspx";}catch(e){'_FFCmd_Err';};
__FFRecv: http://www.webpage.com/members/�JMPA-$ERGiO.aspx
_FFOpenURL ==> No match: http://www.webpage.com/members/ÐJMPA-$ERGiO.aspx
_FFLoadWait: ...... loaded in 1411ms
__FFSend: FFau3.xpath=null;try{FFau3.xpath=window.content.document.evaluate("//table/tbody/tr/td/h3",window.content.document,null,XPathResult.BOOLEAN_TYPE,null).booleanValue;}catch(e){'_FFXPath_Error: '+e;};
__FFRecv: 0

Look at the _FFRecv:

__FFSend: try{window.content.document.location.href="http://www.webpage.com/members/ÐJMPA-$ERGiO.aspx";}catch(e){'_FFCmd_Err';};
__FFRecv: http://www.webpage.com/members/�JMPA-$ERGiO.aspx

Does someone have an answer for this.

Thanks in advance,

Edited by n8gk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×