Sign in to follow this  
Followers 0
sambalec

Problem with unicode ( UTF-8 )

2 posts in this topic

Hello, How can I watch Unicode on MsgBox in autoit ? ( Using win XP )

CODE
$unicode = "козерог"

Msgbox(0,"Unicode",$unicode)

The result is very bad :-(

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

I'm providing this code just for a quick example. How you achieve the $sOut result is up to you. This should give you an idea of what will have to be done. Copy the contents of your original post onto the clipboard and then run this code.

;
$unicode = StringSplit(ClipGet(), "", 2)
$sOut = ""
For $i = 0 to ubound($unicode)-1
   $sOut &= ChrW(AscW($unicode[$i]))
Next
MsgBox(0, "Result", $sOut)
;

Edit: I'm not positive but I think that you can use Asc instead of AscW in there but I played it safe.

Edited by GEOSoft

George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0