Jump to content
Sign in to follow this  
cypher175

IE Proxy Not Updating After Registry is Changed..?

Recommended Posts

cypher175

i made a lil script to get a proxy list from a .txt file online, so it changes these 2 registry keys:

RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings", "ProxyEnable", "REG_DWORD", "1")
RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings", "ProxyServer", "REG_SZ", $ProxyIP)

after that i have it _IENavigate($IE, "http://ip-address.domaintools.com/") to see what the IP of the proxy that I'm using is..

and after that it changes the proxy IP and revisits that page again.. to see if my IP has changes..

But the IP keeps coming back the same Proxy IP every time, even though the registry says its different and so does the proxy settings in the IE Options..

Does IE have to restart for the new proxy IP to take place or is there something else that im missing here..??

Share this post


Link to post
Share on other sites
cypher175

Anybody know why the new proxy IP's aren't updating after the reg keys are changed..??

Share this post


Link to post
Share on other sites
Khab

As far as I know, IE needs to be restarted to re-read the registry keys for this setting.

Share this post


Link to post
Share on other sites
cypher175

how come when using $IE = _IECreateEmbedded() inside a GUI it doesn't use the IE Proxy that is set in the IE options..??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.