Jump to content
Sign in to follow this  


Recommended Posts


I have been using the Autoit version that allowed me to use RunasSet until recently when I started using GUI. Because of this I have had to upgrade to the newer version which removes RunasSet and replaces with Runas / RunasWait

I seem to be having difficulty now controlling / detecting the existence of a window. I am running an installation which does a silent install then at the end asks me for a reboot. I have the window detection in an adlib and this never sees the window now I am using the new RunAs command

I have tried with the logon_flag for 0 and 1 (Option 2 for network credentials only fails to even start up the program)

Is there something simple I am doing wrong or not understanding ... I have built quite a few systems using the RunasSet version of Autiot. I used to update my version on a regular basis to get the benefits but when I realised the RunasSet was removed I tried the new RunAs but failed to get it working so I avoided it until now.

Any help appreciated

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.