Sign in to follow this  
Followers 0
Michael Lester

_IEFormGetObjByName stopped working on IE 7.0

3 posts in this topic

I have a script thst opens a web page and writes values to a couple of text input fields. This script worked for months and then stopped working. The function _IEFormGetObjByName was no longer returning an object that could be used by the next line "_IEFormElementGetObjByName".

In trying to debug the problem I tried to run the short example provided in the help files and got the same result (shown below).

The only major system change I could remember was installing Office 2007 . I was IE 7.0 before and atill am 7.0 but may be a different sub version (now I am at 7.0.5730.13). I have numerous other AutoIt scripts that run perfectly (that do not use _IEFormGetObjByName).

Could it be some security issue about my computer writing to a web page. I don't remember changing anything.?

Anyone else experiencing this problem, or has a solution ??????

; *******************************************************

; Example 1 - Get a reference to a specific form by name. In this case, submit a query

; to the Google search engine. Note that the names of the form and form

; elements can be found by viewing the page HTML source

; *******************************************************

;

#AutoIt3Wrapper_run_debug_mode=Y

#include <IE.au3>

$oIE = _IECreate ("http://www.google.com")

$oForm = _IEFormGetObjByName ($oIE, "f")

$oQuery = _IEFormElementGetObjByName ($oForm, "q")

_IEFormElementSetValue ($oQuery, "AutoIt IE.au3")

_IEFormSubmit ($oForm)

=========================================================================

>"C:\Program Files\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\temp\_IEFormGetObjByName.au3"

--> IE.au3 V2.4-0 Error from function _IEFormElementGetObjByName, $_IEStatus_InvalidObjectType

--> IE.au3 V2.4-0 Error from function _IEFormElementSetValue, $_IEStatus_InvalidDataType

--> IE.au3 V2.4-0 Error from function _IEFormSubmit, $_IEStatus_InvalidObjectType

>Exit code: 0 Time: 2.115

Share this post


Link to post
Share on other sites



You could have exhausted some system resource or more likely have an iexplore.exe process running on your system that is not responding properly. One of the following should clear this issue: 1) Kill all iexplore.exe processes, 2) logout, 3) reboot, 4) reinstall windows, 5) buy a new computer, 6) get a job at WalMart instead.

Typically you don't need to go past step 1)


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0