Jump to content
Sign in to follow this  
sagdude

#AutoIt3Wrapper_Change2CUI = y option

Recommended Posts

sagdude

Hi

I am using this option in my AutoIt script so that the ConsoleWrite messages are shown in the dos window.

I compile the script and run it from the startup folder of Windows XP.

Until recently(like a week ago), the AutoIt script would pop up the dos window and show the ConsoleWrite messages.

But now, it doesn't seem to be doing so.

Any help is appreciated.

Thanks,

Raj

Share this post


Link to post
Share on other sites
Inverted

You mean, the same compiled script stopped working ?

Or newly compiled ones ?

Share this post


Link to post
Share on other sites
sagdude

You mean, the same compiled script stopped working ?

Or newly compiled ones ?

Thanks for your reply Inverted.

The newly compiled one stopped working (well it did not stop working but it stopped displaying messages in the

console window, in fact there was no console window but the script was doing its work in the back ground).

Another strange thing I noticed was: I added a test message on the top of the script like:

CODE
ConsoleWrite("This is a test Message" & @CRLF)

Sleep(5000)

and (recompiled it ) and it started showing the console window!

Now I removed that test message(and recompiled it) and it is still showing the console window!

I did not change anything else in the program.

I am using AutoIt version 3.3

Thanks,

Raj

Share this post


Link to post
Share on other sites
sagdude

Thanks for your reply Inverted.

The newly compiled one stopped working (well it did not stop working but it stopped displaying messages in the

console window, in fact there was no console window but the script was doing its work in the back ground).

Another strange thing I noticed was: I added a test message on the top of the script like:

CODE
ConsoleWrite("This is a test Message" & @CRLF)

Sleep(5000)

and (recompiled it ) and it started showing the console window!

Now I removed that test message(and recompiled it) and it is still showing the console window!

I did not change anything else in the program.

I am using AutoIt version 3.3

Thanks,

Raj

Hi

It was my mistake. I was compiling (using right click and then compile) without choosing it "compile with options" when it did not work!

Thanks,

Raj

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.