Sign in to follow this  
Followers 0
picea892

Windows 7 taskbar Redux [Final]

41 posts in this topic

#1 ·  Posted (edited)

Pretty self explanatory title of what the topic is.

I've tried doing this before but was less then satisfied with result.

This one has worked out really well, partially because I've gotten better at scripting but also because now I've actually used a Windows 7 machine so I now how it should work.

Enjoy

Picea

PS: You might have to move your real taskbar in order to use it....

Latest update has an option to hide taskbar. In order to ensure you get the taskbar shown again, need to do one of the following:

1) Exit script using Shift and Esc.

2) Right click taskbar and select don't hide taskbar and press the submit button.

3) Change the ini file to not hide taskbar (change taskbar to 0) and rerun the script.

Updated June 11 - no focus added

Updated June 11 - Increased array dimensions

Updated June 13 - Pin/unpin icons and icon context menus

Updated June 13 - When icon clicked minimize window if restored/maximized and active

Updated June 15 - Colour schemes, menu transparency options, Taskbar Right click, close button, close group; Kill taskbar on start option

Updated June 18 - Added shortcuts - Drag and drop to add, Right click icon to execute

Updated June 28 - Optimized using shell hook; Submenu now with icons, centered, sized to fit text, right click to delete; Main icon - double click minimize, single click activate

Updated July 02 - Added secondary pinned bar, click clock to access, supports drag and drop

post-45064-1246552975_thumb.jpg

post-45064-1246552981_thumb.jpg

oneventtaskbar7.au3

Edited by picea892

Share this post


Link to post
Share on other sites



Hi,

When I run it I am getting an error saying there is no sub section "No Array." $2ndsublist[$k][1]=$winlistall[$k][1]

>Running AU3Check (1.54.14.0)  from:C:\Program Files (x86)\AutoIt3
C:\oneventtaskbar.au3(181,39) : WARNING: $hGui: possibly used before declaration.
    $Clr = _ChooseColor(2, 0, 2, $hGui)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\oneventtaskbar.au3(183,28) : WARNING: $iColor possibly not declared/created yet
        $iColor[$iD] = $Clr
~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\oneventtaskbar.au3(185,40) : WARNING: $Label: possibly used before declaration.
            GUICtrlSetColor($Label[$iD],
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\oneventtaskbar.au3(471,19) : WARNING: $iconwin: possibly used before declaration.
GUIDelete($iconwin)
~~~~~~~~~~~~~~~~~~^
C:\oneventtaskbar.au3(181,39) : ERROR: $hGui: undeclared global variable.
    $Clr = _ChooseColor(2, 0, 2, $hGui)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
C:\oneventtaskbar.au3 - 1 error(s), 4 warning(s)
!>22:27:46 AU3Check ended.rc:2
+>22:27:54 AutoIt3Wrapper Finished
>Exit code: 0   Time: 8.513

Share this post


Link to post
Share on other sites

Hi Gseller....are you saying you couldn`t get the code to run at all? I've never gotton that error but could see that could be a very valid error. If the adlibenable timer clicks on just as something is being reloaded it would give that error. I had isarray checks already in place but missed that one.

Added "IsArray($2ndsublist)=1" in the appropriate spot. The other warnings you show below were thrown by the presence of an unused function and shouldn't impede use. I have deleted that function and declared the global variable at the start instead of in a function. I get no warnings in Scite now when I run it. I never run my scripts in Scite and forget about that useful test.

I will upload a corrected version

Appreciate you testing for me.

Picea

Share this post


Link to post
Share on other sites

I get to see bar for about 10 seconds before i get this error.Hope you can sort that out.Because the bar looked real good.Like to give a real test run though.Good-Luck.

=====\Downloads\AutoIt\New AutoIt v3 Script.au3 (389) : ==> Array variable has incorrect number of subscripts or subscript dimension range exceeded.:
$2ndsublist[$k][1]=$winlistall[$k][1]
^ ERROR

Share this post


Link to post
Share on other sites

Well this is somewhat disappointing. I've used on a Vista and XP machine and done whatever I can to get the error but doesn't appear. It's hard to fix it unless you can find it :D . It looks like it must occur when you hover the icons. I'll see what I can do to diagnose it. In the meantime....I'm really enjoying using it

As an aside. Froufrou that's a nice picture.

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Looks good! It needs some optimizing though...

Is the window which appears with the title of the application of the icon you're hovering above (Title Window?) suppossed to be taking focus from the window that's in use?

Every time I hover above an icon the window in use loses focus and then get's it back

Edited by AoRaToS

s!mpL3 LAN Messenger

Current version 2.9.8.8 [30/09/2015]

Download Here

s!mpL3

Share this post


Link to post
Share on other sites

Good point

added some strategically placed GUISetState(@SW_SHOWNOACTIVATE) and that seems to fix the problem.

I am certain that some GDI master could probably optimize the repaint using $RDW_NOERASE or $RDW_NOINTERNALPAINT. I have tried but without too much success.

Other than that there probably other tweaks which should be done.

Share this post


Link to post
Share on other sites

Hi,

I just tried it again and I am getting this error when I mouse over an icon

>Running:(3.3.0.0):C:\Program Files (x86)\AutoIt3\autoit3_x64.exe "C:RTF2HTML Conversion\oneventtaskbar2.au3"   
C:\RTF2HTML Conversion\oneventtaskbar2.au3 (391) : ==> Array variable has incorrect number of subscripts or subscript dimension range exceeded.:
$2ndsublist[$k][1]=$winlistall[$k][1]
^ ERROR
->11:13:01 AutoIT3.exe ended.rc:1
+>11:13:02 AutoIt3Wrapper Finished
>Exit code: 1   Time: 18.941

I am running vista x64.. Not sure if this makes a difference or not..

Share this post


Link to post
Share on other sites

As an aside. Froufrou that's a nice picture.

I don't know if that was sarcasm.But yeah I think its a beautiful picture.And if it wasn't sarcasm Thanks.

Share this post


Link to post
Share on other sites

Hi Frou Frou

Don't be offended, no sarcasm intended. It's simply a noteworthy avator and certainly a better avator than most I have seen. Note that I don't have one yet. I'm still looking for the perfect one. Maybe a nice black spruce...Picea is latin for spruce.

Anyways back to the topic at hand....I think I know the problem but need to ask a question. Are you or Gseller running more than 10 windows? If you are then I have not dimmed a big enough array. I guess I never run more than 9 windows and so assumed others wouldn't either. My error. If that is the source of the error then there are two points where this line exists.

dim $2ndsublist[10][6]

Other than that, I guess I may need to take a shotgun as a solution and rewrite a portion of the script.

Could others confirm if it is working for them?

Share this post


Link to post
Share on other sites

@ picea892

Not offended at all :D

In this "dim $2ndsublist[10][6]"----Could i just change something here to allow more windows to see if that's the problem for me?

Share this post


Link to post
Share on other sites

That'd be great if you could try.

Just search for that line - dim $2ndsublist[10][6]

Line 30 and line 382 in my version (might be different, I keep tweaking)

and change it to something like dim $2ndsublist[20][10]

Just to be safe.

Much appreciated. If it works, I'll change the first post.

Share this post


Link to post
Share on other sites

Well before i read you post i had changed those to "dim $2ndsublist[50][45]" :D Cause I didn't know what i was doing.

But it Worked perfectly :D .

After reading you post i changed it to what you recommended,and it crashed immediately,But i already had opened lots,lots and lots of windows for testing my changes.And on another note how do i get to NOT show certain windows?Like it shows the Vista sidebar with a listing of each gadget on hover.But if that's to much trouble i can live with it.

Share this post


Link to post
Share on other sites

That's great news. I'll make the change in the first post. I'll stick with 20, that should serve most people. Thanks for your help!

I made two exclusion lists.

line 68 and 69 in my version. One uses titles and the other uses classes. There is a auto-info tool you may have used before. It's in the autoit directory. Use that to get the title or class of the sidebar and add it to one of the lists and you are in business.

Local $sExclude_List = "|Start[CL:102939]|Start|Desktop|Start Menu[CL:102938]|taskbar|iconwin|desktop[CL:102937]|Program Manager|taskbar|Menu|Save As|Drag|"

Local $sExclude_class = "|tooltips_class32|gdkWindowToplevel|gdkWindowTempShadow|TaskSwitcherWnd|gdkWindowTemp|bosa_sdm_

Microsoft Office Word 11.0|MsoCommandBarPopup|MsoCommandBarShadow|NUIDialog|CallTip|ThumbnailClass|#32770|Desktop User Picture|OfficeTooltip|"

Share this post


Link to post
Share on other sites

Working PERFECT for me :D

Share this post


Link to post
Share on other sites

#16 ·  Posted (edited)

You can probably ReDim the array to the number of windows in WinList() to be more sure? Maybe that can be a start and you can work up from that...

Edited by AoRaToS

s!mpL3 LAN Messenger

Current version 2.9.8.8 [30/09/2015]

Download Here

s!mpL3

Share this post


Link to post
Share on other sites

Haha, nice one mate :D

Share this post


Link to post
Share on other sites

Nice! Working great now! Kudos!

Share this post


Link to post
Share on other sites

Glad it's working for everyone now. Aoratos, I'll take your advice next time I upload a new version. My next version will have the ability to pin and unpin icons.

James Brook. If you're willing, I'd love it if you could help me rig up glass. I have tried but can't seem to get the icon guictrlpic to show properly above the glass background. I also can't apply it to the guictrlpic's. If it is the Guictrlpic's giving the headache, I suppose for a variation I could rig it, so if vista build the icon controls as guictrlicons and guictrllabels or something like that. In truth I had really made this for my Win Xp machine and am not really that fond of glass and so never pursued further. I think on that last note, given the number of views Vista glass and Glass Cmd get I am in the very small minority :D

So anyways, Can you take a look at my attached attempt? Is there anything to be done?

Picea

oneventtaskbar2.au3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0