Jump to content
Sign in to follow this  
Guest Armypunk

Send Command...

Recommended Posts

Guest Armypunk

Maybe it's me or my send command syntax but I just can't get this to work. I am trying to set a variable equal to a user configured function key - F1, F2, F3 etc that is read from an .ini file. Everything works till I hit the Send command and it only spits out a $. Any ideas?

As an example lets say the ReadIni has set $fkey = "F1"

Send("{$fkey}") <---- Doesn't work only spits out a $

What am I doing wrong?

This is syntax direct from help file:

Sends simulated keystrokes to the active window.

Send ( "keys" [, flag] )

{F1} - {F12} Function keys

I tested and verified that $fkey does equal F1, I also tried hardcoding as follows and it worked:

Send("{F1}")

Really at a loss and all help would be appreciated. TIA

Share this post


Link to post
Share on other sites
Guest Armypunk

Larry,

Thanks so much, it works like a charm! Now I am just wondering where in the documentation is mentions that? I quickly reviewed it and didn't see it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.