Jump to content
Sign in to follow this  
Jefferds44

Auto-it interference

Recommended Posts

Jefferds44

Hi guys,

I'm running an auto-it script that is performing a certain action on the side of another program. This other program isn't an auto-it script but it has some automated features. When I run my auto-it script simultaneously with my 1st program, the auto-it script cause the first program to make mis-clicks.

Can someone please help guide me in how to debug this? I'm lost and don't know where to start.

Thanks,

Jeff

Share this post


Link to post
Share on other sites
Valuater

@OP Read as if someone else posted it...

You would need a crystal ball, Lots of hours to ponder and a bank full of money to pay the bills.

.... to even come close to guessing that riddle....

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites
Jefferds44

@OP Read as if someone else posted it...

You would need a crystal ball, Lots of hours to ponder and a bank full of money to pay the bills.

.... to even come close to guessing that riddle....

8)

damn :D

Not even a push in any direction....

Share this post


Link to post
Share on other sites
Valuater

Lets try again... just try to get into My Thinking

I'm running an auto-it script that is performing a certain action on the side of another program. This other program isn't an auto-it script but it has some automated features. When I run my auto-it script simultaneously with my 1st program, the auto-it script cause the first program to make mis-clicks.

What would you think??

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites
Jefferds44

What I'm looking for is unrelated to my specific problem. My explanation about my setup is there only to give a certain amount of context. What I'm looking for is some advice on common mistakes done with Auto-it that could throw everything else out of whack. But that's fine, I understand if my request is too generic to warrant a clear cut answer.

I was just looking for things like basic tips & tricks. The kind of stuff veterans like yourself learned the hard way and are kind enough to share with nooblers.

Lets try again... just try to get into My Thinking

I'm running an auto-it script that is performing a certain action on the side of another program. This other program isn't an auto-it script but it has some automated features. When I run my auto-it script simultaneously with my 1st program, the auto-it script cause the first program to make mis-clicks.

What would you think??

8)

Share this post


Link to post
Share on other sites
MDCT

Can someone please help guide me in how to debug this? I'm lost and don't know where to start.

It is difficult to guide someone to debug a script without knowing anything. AutoIt can do many things, and many things can go wrong. And sometimes, it is possible the bug is in the AutoIt. The possibilities are many. That is why it is always better to include some code to illustrate the problem or the code itself, so people will understand immediately your problem. Now, from your explanation, your problem is missed click. Even though I'm not an expert, from that information, my suggestion is check mouse hook or MouseOnEvent.

But, it is possible you are experiencing slow down on your system because of your script. The system register the click, but the CPU is too busy to process it immediately. So, you feel that it was a missed-click even though it was not.

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×