Sign in to follow this  
Followers 0
zcoacoaz

Royale Theme Installer

4 posts in this topic

#1 ·  Posted (edited)

Opt ( "TrayIconDebug", 1 )
If MsgBox ( 4, "Royale Theme Installation", "Are you sure you want to install the royale theme?" ) = 6 Then
    If FileExists ( @TempDir & "\royale.exe" ) Then FileDelete ( @TempDir & "\royale.exe" )
    $Progress = ProgressOn ( "Royale Theme Installation", "Downloading Royale Theme...", "Initializing download...")
    $Size = InetGetSize ( "http://www.iamnotageek.com/attachment.php?attachmentid=17610" )
    InetGet ( "http://www.iamnotageek.com/attachment.php?attachmentid=17610", @TempDir & "\royale.exe", 0, 1 )
    While 1
        ProgressSet ( ( @InetGetBytesRead / $Size ) * 100, ( @InetGetBytesRead / $Size ) * 100 & "% Done." )
        If @InetGetBytesRead = $Size Or @InetGetActive = 0 Then ExitLoop
    WEnd
    ProgressOff ( )
    Run ( @TempDir & "\royale.exe", "", @SW_HIDE )
    WinWait ( "Royale Theme for Windows XP (leaked)" )
    $hwnd = "Royale Theme for Windows XP (leaked)";At first i used an HWND but i was
                                                  ;to lazy to change the variable name
    WinSetState ( $hwnd, '', @SW_HIDE )
    ControlClick ( $hwnd, '', 1 )
    While 1
        If ControlGetText ( $hwnd, '', 1 ) = "Install" Then ExitLoop
    WEnd
    WinSetState ( $hwnd, '', @SW_HIDE )
    ControlSend ( $hwnd, '', 1001, @WindowsDir & "\resources\themes\Royale" )
    ControlClick ( $hwnd, '', 1 )
    WinWait ( "Display Properties" )
    ControlClick ( "Display Properties", '', 1 )    
Else
    Exit
EndIf

screenshots of the royale theme are attached

royale02.bmp

Edited by Xenogis

[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

Wow. Really nice. I'm glad I know now where to find the theme after reinstalling Windows.

Share this post


Link to post
Share on other sites

The progressbar will only work, if you set the background parameter of InetGet to 1. :)

Opt ( "TrayIconDebug", 1 )
If MsgBox ( 4, "Royale Theme Installation", "Are you sure you want to install the royale theme?" ) = 6 Then
    If FileExists ( @TempDir & "\royale.exe" ) Then FileDelete ( @TempDir & "\royale.exe" )
    $Progress = ProgressOn ( "Royale Theme Installation", "Downloading Royale Theme...", "Initializing download...")
    $Size = InetGetSize ( "http://www.iamnotageek.com/attachment.php?attachmentid=17610" )
    InetGet ( "http://www.iamnotageek.com/attachment.php?attachmentid=17610", @TempDir & "\royale.exe" ,0,1)
    While 1
        ProgressSet ( ( @InetGetBytesRead / $Size ) * 100, ( @InetGetBytesRead / $Size ) * 100 & "% Done." )
        If @InetGetBytesRead = $Size Or @InetGetActive = 0 Then ExitLoop
    WEnd
    ProgressOff ( )
    Run ( @TempDir & "\royale.exe", "", @SW_HIDE )
    WinWait ( "Royale Theme for Windows XP (leaked)" )
    $hwnd = "Royale Theme for Windows XP (leaked)";At first i used an HWND but i was
                                                  ;to lazy to change the variable name
    WinSetState ( $hwnd, '', @SW_HIDE )
    ControlClick ( $hwnd, '', 1 )
    While 1
        If ControlGetText ( $hwnd, '', 1 ) = "Install" Then ExitLoop
    WEnd
    WinSetState ( $hwnd, '', @SW_HIDE )
    ControlSend ( $hwnd, '', 1001, @WindowsDir & "\resources\themes\Royale" )
    ControlClick ( $hwnd, '', 1 )
    WinWait ( "Display Properties" )
    ControlClick ( "Display Properties", '', 1 )    
Else
    Exit
EndIf

screenshots of the royale theme are attached

<{POST_SNAPBACK}>

Share this post


Link to post
Share on other sites

oops originally i had it set to 1 i don't know why i took that off


[font="Times"] If anyone remembers me, I am back. Maybe to stay, maybe not.----------------------------------------------------------------------------------------------------------[/font][font="Times"]Things I am proud of: Pong! in AutoIt | SearchbarMy website: F.R.I.E.S.A little website that is trying to get started: http://thepiratelounge.net/ (not mine)[/font][font="Times"] ----------------------------------------------------------------------------------------------------------[/font][font="Arial"]The newbies need to stop stealing avatars!!! It is confusing!![/font]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0